Jam doesn't work

OK, I Downloaded all the tools and did an svn checkout. I ran

./configure --target=haiku


jam haiku-image

it seems to run for a short while then scrolls continuously

“warning: unknown rule break”

so much for building my own haiku image file.

Strange - what OS are you building on?

Also try re-running “svn up” in your project directory - sometimes the svn checkout doesn’t finish properly.

You can also try “jam -q haiku-image” which will make it stop on the first failed target instead of continuing on. That might yield some clue as to what failed.

I am using BeOS MAX 4.1 and have tried all these suggestions … same issue.

you can use -v to increase the verbosity of the jam output also…

check the jam commandline options for more info

You are using the Haiku version of Jam from the buildtools branch right?

you can use -v to increase the verbosity of the jam output also

how ???

You are using the Haiku version of Jam from the buildtools branch right??? I downloaded Jam from the website and installed.

I re-downloaded jam, and now I’m jammin!

Oops, I meant you can use -d to change the output of jam (I was thinking -v from other tools)…

-d has different debug levels…

Anyhow, I’m not even sure the version of Jam on the website is up-to-date - it’s probably safer to get jam from the buildtools branch, build it, and install it from there. Glad to hear downloading a new version fixed your problem though :slight_smile:

Where is the “buildtools branch?”

I love it when people assume too much.

It seemed to jam but in the end …

…skipped haiku.image for lack of haiku.image-copy-files…
…failed updating 1 target(s)…
…skipped 2 target(s)…
…updated 1840 target(s)…

no haiku.image to test.

You’re right - I assumed… (there are probably a dozen posts here in the forums and mailing list about it) - anyhow, the old website article used to actually specify how to get it, but that’s been mostly replaced with jam.zip download link now…

UPDATE: I just checked, and it appears the version for download is already up-to-date - nothing has changed since 20060813

The Linux dev tools page still explains how to get it:


You don’t need the entire buildtools though - just buildtools/trunk/jam:


You can “svn co” just that directory from the repo.

In any case, you will need to run “jam -q haiku-image” if you want it to stop on the target that failed.

I poked around the svn repository and guessed the svn command to download … it would be nice if install instructions were included in the directory … after making the files I followed the install instructions from the jam zip directory and am trying the jam again.

Link generated/objects/haiku/x86/release/add-ons/tracker/filetype/FileType-F
XRes1 generated/objects/haiku/x86/release/add-ons/tracker/filetype/FileType-F
Chmod1 generated/objects/haiku/x86/release/add-ons/tracker/filetype/FileType-F
SetType1 generated/objects/haiku/x86/release/add-ons/tracker/filetype/FileType-F
MimeSet1 generated/objects/haiku/x86/release/add-ons/tracker/filetype/FileType-F

generated/objects/r5/x86/release/tools/mimeset -f “generated/objects/haiku/x86/release/add-ons/tracker/filetype/FileType-F” ;

…failed MimeSet1 generated/objects/haiku/x86/release/add-ons/tracker/filetype/FileType-F …
…removing generated/objects/haiku/x86/release/add-ons/tracker/filetype/FileType-F
…skipped haiku.image-copy-files-dummy-beos/system/add-ons/Tracker for lack of FileType-F…
…skipped haiku.image for lack of haiku.image-copy-files…
…failed updating 1 target(s)…
…skipped 2 target(s)…
…updated 263 target(s)…

Yes I downloaded the add-ons/Tracker directory again and this is the result. I guess building Haiku just isn’t for me. I’m lost.

Interesting - that’s a recent issue reported on the dev mailing list… I thought it was Linux-specific, but maybe not.

In any case, I think it will be fixed soon - as there were some discussions about what causes it as well.

(looks like axel mentioned something about deleting the entire “generated” directory and jamming again from scratch)

For the record - after updating my BeOS R5 system with the latest code, I too have this problem now. So, it’s not your environment :slight_smile:

BTW, it appears that r21484 was when the FileType-F started to fail consistently. If you were to revert to r21483, or even just revert the one mimeset.cpp that was changed there, it would probably succeed - I’ll try that tonight.

deleted this line from /src/add-ons/tracker/filetype/Jamfile and the jam completed.

added same vector icon as FileTypes preflet, but somehow the
resources are not added for the “Addon” target type? Ingo?

SubDir HAIKU_TOP src add-ons tracker filetype ;

SetSubDirSupportedPlatformsBeOSCompatible ;

TODO: does not seem to work:

AddResources FileType-F : FileType.rdef ;

Addon FileType-F :

: be tracker


It’s possible that mmlr has even fixed the problem now in r21515 by adding a newer BMessage implementation to libbe…

Nope, apparently it is now supposedly fixed in r21518:


I’ll check when I get home :slight_smile:

I am posting from haiku rev 2159 after compiling on my system … !!!


What is this supposed to mean?

Awesome, welcome aboard Jim. If you can program at all, maybe you can start fixing bugs and sending patches. Building your own Haiku is the first step on the journey to being a Haiku contributor! :smiley: