Issues installing+booting Haiku on a big-boss desktop with W10


#1

Hi to all,

succeded to install Haiku on my old laptop (without other OSes), not it’s time to put into the big-one, my desktop workstation.

Well, lot of issues here unfortunately…

1- Boot from usb sticks, had to use an usb plug from the MoBo, as my internal 3.5 CF+USB3 hub made me on KDL (dunno if it’s because the hub or because of being on USB3). Boot was perfect and put me on Desktop in VESA mode (i guess my Nvidia Quadro is not supported)

2- Installing on a 32gb internal SSD (NOT my primary SSD disk with W10), init as Intel partition map. Installation OK

3- Trying to install bootmap from Installer, I soon noticed that the W10 partition is not recognized…this is because it is on another disk?

4- Writing the boot sector, bootman failed with a useless “Impossible to write boot sector” message

5- While rebooting, the boot fails over W10 boot manager even if the Haiku SSD disk has higher boot priority

Additionally, very often (need to undestand why “often” and not “always”) when booting, I automatically get into the boot menu when I can see screen resolution to “none”. I set. Then I’m forced to hit ‘Reboot’ and I go into W10 instead (this is really irritating :rage:)

Finally (but I think this is know issue) I have no audio from my display port and neither HDMI port. Also no audio from optical output on Mobo. Analogue outputs works perfectly. These are the only output choices in media preflets. This is due to VESA mode I guess but…what about optical? Still not supported?

I’m enjoing Haiku on the laptop, but that’s so old and worn…I can’t wait to use it on my desktop box now :slight_smile:


#2

Ok, on such a “Power Machine” i’d suggest to run Haiku on a VM.
The other option is to install grub… which is a little more difficult and risky.
BTW… the Windows Boot Manager is crap… so just forget it :wink:

Me for myself, installed Linux Mint and then VMs for Windows and Haiku. Works perfect.


#3

I’m not sure you get audio from HDMI audio on Haiku with any recent cards if any at all and especially not Nvidia cards as they lack documentation? Radeon HD works with GCN cards older than polaris so like a 280X probably works etc… Radeon Output ports I believe there is some work to get displayport working by YMMV.

If you want to boot Haiku on a Higher end machine you really need one that is several years old, Intel or Radeon graphics that is several years old etc… even then the different more complex pcie bus architecture of higher end machines may not play nice.


#4

tnx for feedback

by the way, the big-boss is not so high-end. It used to be in 2012 and in some ways it’s even now (liquid cooler, noctua fans, aluminium case, nvidia quadro, ram xtreme profile). But it’s definitively just an i7 guy :slight_smile:

i was wondering if it’s possible to install grub without linux. I’ve no need of the penguin here, as I’ve a bounce of raspberry pis hanging down everywhere doing nerdy stuff already

no intent to use windows boot manager actually, but if haiku bootman doesn’t boot my w10-pay-the-mortage disk, this is going to become a real problem…


#5

Yep, you can install grub2 under Windows. But as i said, its kinda risky. So you better backup you data before.


#6

I use EasyBCD and just add Haiku to the windows bootloader and disable the Metro bootloader gui… so I don’t have to wait for windows to actually boot for it to show me a bootloader menu.

I can also reccomend syslinux as a bootloader on PC’s that have Linux installed, it has an understandable settings file reminicent of grub 1.x unlike grub2 which no offence is an absolute steaming pile of garbage :smiley:


Looking for a Haiku Beta Motherboard
#7

looks definitively the best solution. Do you have a detailed guide on how to proceed? it would be nice for the entire Haiku noobs community (well, and to me :D), having one…


#8

#9

Ok, lot of improvements but still some issues (and a very troubled installations among boot partitions not found on USB stick, no keyboard in drivesetup, no mouse in the desktop…)

Said that Haiku is bootabe from EFI if I push it on top priority at BIOS, let’s close this world (and open the next @extrowerk :slight_smile:)

1- No way to use EasyBCD due to W10 restrictions
2- Installed ubuntu and grub2
3- Set the partitions from Installer. For some reason, Haiku’s DriveSetup fails when I try to force 32 bit while formatting the EFIBOOT partition. I left to “Auto” and DriveSetup says it’s a FAT32 but DiskSetup in Ubuntu reveals it’s 16bit (!!!). I copied the /EFI/BOOT/BOOTX64.EFI there, no prob.

At this stage I’ve a bootable Haiku install, but no grub integration

Following the official guide:

4- added GRUB_HIDDEN_TIMEOUT=0 in /etc/default/grub (it was not present at all in my file)

5- Added this entry on 40_custom file

menuentry "Haiku" {
	load_video
	insmod part_msdos
	insmod chain
	search --fs-uuid --set=root 51e6a34f-d4db-c840-aad6-ead59e3523fc
	chainloader ($root)/EFI/BOOT/BOOTX64.EFI
}

6- sudo update-grup then reboot.

Weird enough there’re two “Haiku” menu entry in grub and boot of them won’t boot giving the same two errors: i. no such device (a uid i cannot see elsewhere, actually) ii. cannot find file /EFI/BOOT/BOOTX64.EFI

So I commented all the custom settings just added in 40_custom and push grub-update. Indeed, in the menu I see only one entry ‘Haiku’ now, but the error stays the same.

P_20181012_013027

have I miss something?

EDIT: output of sudo blkid

/dev/sdc1: SEC_TYPE="msdos" LABEL="EFIBOOT" UUID="05FE-2400" TYPE="vfat" PARTLABEL="EFIBOOT" PARTUUID="51e6a34f-d4db-c840-aad6-ead59e3523fc"
/dev/sdc2: LABEL="Haiku" UUID="13b7d8200ace26fd" TYPE="befs" PTTYPE="atari" PARTLABEL="Haiku" PARTUUID="75c0840e-5865-cd40-832a-20b6cf2e591c"

EDIT2: Problem solved. I leave here as it could help others

  • This is not the PARUUID the string to be used in grub config but UUID (in my case: 05FE-2400)

  • The duplicate was due to previous submission of grub generation file (I though it works in replace but apparently it works in append). Being lazy, I switched to a GUI deb package to clean up the mess (GrubCustomizer)

finally Haiku on bare metal on my big desktop i7 guy :slight_smile:


#10

Not sure what you mean EasyBCD works fine in Windows 10. The only catch is if you get a major windows update you have to boot up windows and resave the bootloader config in EasyBCD .


#11

Fall 2018 update: upon installation EasyBCD warns me that due to MS restriction on executing non-Windows kernel, the app would have some limitations. Among the remediations, the best one was to install grub2 so i did and it works like a charm (ok I’m wasting 50gb of SSD space for a Linux install I’ll never use again but who cares=


#12

That may be secureboot related… I guess I’ll see once I get that update (which sounded like it was a steaming pile of garbage considering it was deleting people’s files during the update).