Is mounting/unmounting of USB thumbdrives still a little twitchy?

More often than not, when I plug in a USB thumb drive, it comes up, but when I unmount it and then try to mount it again, I get an error message. And sometimes, when I unmount it, the icon for the thumb drive doesn’t go away, but the green capacity bar drops to almost 0. Other times, when I unmount it, it disappears (from the Desktop) like it’s supposed to, but it’s still showing in DriveSetup and I can’t mount it again and I get the error message. Seems either there is a method for doing this that I’m not doing in the right order or USB (at least for thumb drives) is still a little wonky?


Sometimes I get more serious issues when unplugging USB Mass Storage devices like deadlocks in kernel. It cause freeze of any mount menu and DiskPart. Plugging new USB Mass Storage also stop working until reboot.

It seems that probability of getting deadlock is higher when DiskPart is opened during unplug.

1 Like

I can confirm that I have seen what @Luposian described sometimes but I didn’t try to narrow it down more…was not so severe to create a ticket…

That’s probably because the “eject when unmount” setting in the tracker settings is enabled?, i had the same issue, after i disabled it, i was able to mount & unmount as often as i want.

These aren’t USB (stack) problems specifically but with either the usb_disk driver or hot-plugging disks overall.

Is there a ticket already for it? Or should I create one?

With a Thumb drive, I assume “Eject when unmount” should be the normal function, as I have to eject my thumb drives before unplugging them on my Windows 11 laptop. Or at least I make sure I do, to prevent any possible data corruption.

UPDATE: I unchecked the “Eject when unmounted” box and seem to see the same result. No more glitch. However, as an added bonus, I was now able to Initialize my USB Thumb drive (that option was not available before)! I made it a GUID partition and then formatted it via BFS. So far, so good. We’ll see how it goes over time.

UPDATE 2: Apparently, still, sometimes when I unmount, the capacity meter drops to almost zero and the image stays there. I was able to mount it via DriveSetup, but suddenly a second image pops up behind it. When I move the mounted USB drive out of the way, I see a filing cabinet with a zero’d capacity meter! I can mount and unmount the USB thumb drive image, but the Filing cabinet will never go away and it’s capacity never changes from zero. I try to delete it (trash it) and Haiku says it can’t! What’s going on in this situation? Crazy! :crazy_face:

8 posts were split to a new topic: How to change the icon of a volume/drive?

There is a bug where somehow the unmount process does not fully complete, so you end up with a device that’s partially unmounted, but not completely. Tracker does not expect this to happen and is a bit confused.

I think we have not yet found exactly why and how this happens. Probably there is something still trying to read or write a file to that disk, but we don’t know what. Or maybe some part of the OS thinks there is some app trying to access files there, but it’s wrong because it miscounted something.

Unfortunately this does not reproduce as easily on all machines. On mine I will only see it from time to time, not reliably enough to be able to investigate more closely.

As of the latest update to Haiku R1/Beta4 (as of a couple days ago), and enabling “Eject” in the Mount settings, it appears my issue is now gone. My thumb drive icon disappears when I unmount it and reappears when I mount it again. I find it strange that it works now, because I’m almost certain I already tried that setting and it didn’t fix it! But maybe something was changed between then and now and that setting now works as intended. Or something… :grin: