Intel hda thinkpad x220 no sound

Hello there, im kinda new to Haiku, just installed it on my X220 laptop, everything seems well, but i have no sound.

~> listdev | grep Audio

device Multimedia controller (Audio device) [4|3|0]
device 1c20: 6 Series/C200 Series Chipset Family High Definition Audio Controller

~> listimage | grep driver
57 0xffffffff818e2000 0xffffffff818e9000 0 0 /boot/system/add-ons/kernel/drivers/disk/virtual/ram_disk
70 0xffffffff8172b000 0xffffffff8172c000 0 0 /boot/system/add-ons/kernel/drivers/dev/dprintf
71 0xffffffff817f7000 0xffffffff817f8000 0 0 /boot/system/add-ons/kernel/drivers/dev/zero
72 0xffffffff817f9000 0xffffffff817fa000 0 0 /boot/system/add-ons/kernel/drivers/dev/null
73 0xffffffff81917000 0xffffffff81919000 0 0 /boot/system/add-ons/kernel/drivers/dev/console
74 0xffffffff814a0000 0xffffffff814ab000 0 0 /boot/system/add-ons/kernel/drivers/dev/tty
863 0xffffffff814c0000 0xffffffff814c2000 0 0 /boot/system/add-ons/kernel/drivers/power/acpi_battery
1002 0xffffffff814c3000 0xffffffff814c5000 0 0 /boot/system/add-ons/kernel/drivers/power/acpi_button
1422 0xffffffff81130000 0xffffffff81138000 0 0 /boot/system/add-ons/kernel/drivers/dev/graphics/intel_extreme
1427 0xffffffff8113f000 0xffffffff81143000 0 0 /boot/system/add-ons/kernel/drivers/dev/graphics/vesa
1517 0xffffffff813c4000 0xffffffff81436000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/ipro1000
1572 0xffffffff81d7c000 0xffffffff81e03000 0 0 /boot/system/add-ons/kernel/drivers/dev/net/iprowifi4965
1618 0xffffffff81882000 0xffffffff81885000 0 0 /boot/system/add-ons/kernel/drivers/dev/input/wacom
2023 0xffffffff81f48000 0xffffffff81f55000 0 0 /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda
2087 0xffffffff81164000 0xffffffff81167000 0 0 /boot/system/add-ons/kernel/drivers/dev/bus/usb_raw
TEAM 16819 (/bin/grep --color=auto driver):

I saw No Sound on HDA Intel this discussion but nothing helpful for me, i cat even configure Open Sound…

Syslog related to hda https://pastebin.com/mAeM2evR

Help me please getting sound work, cuz i like haiku

1 Like

opensound works for me on the X220. You need to install it (pkgman install opensound) and then blacklist the default hda driver by adding

Package 'haiku' { EntryBlacklist { 'add-ons/kernel/drivers/bin/hda' .... } }

to the blacklist file (https://www.haiku-os.org/guides/daily-tasks/blacklist-packages). After that you may need to tweak the settings in Media preferences to route the audio output to the right direction (jack, internal speaker, etc).

This is on x86, I don’t know if opensound is available for 64bit Haiku yet.

1 Like

I’ve done this on 64bit on my X220, works pretty well.

1 Like

My MacBook Pro has the same chipset, I need to boot into another OS first, then reboot into Haiku to have working sound (only on headphone jack).

Yes, it works great in 64-bit! My story is at No sound with Sigmatel 9205 sound device. Hope it helps you to get your sound up and running!!

2 Likes

This should be Package 'haiku' I think.

1 Like

Indeed, I copypasted this from the other blogpost. Edited my reply now.

1 Like

Ty guys for ur replies.
Okay i did this:
installed opensound.

Blacklisted some stuff
~> cat /boot/system/settings/packages
Package haiku {
EntryBlacklist {
add-ons/kernel/drivers/bin/hda
add-ons/media/hmulti_audio.media_addon
add-ons/kernel/drivers/dev/audio/hmulti/hda
}
}

But i still have add-ons/kernel/drivers/dev/audio/hmulti/hda in listimage | grep driver list. And dev/oss/oss_loader too.

In Audio Settings input and output i see 2 options - HDA and just empty line without any title.

osstest says:
Sound subsystem and version: OSS 4.2 (b 2017/201901281229) (0x00040100)

NOTICE! You don't have any audio devices available.
Its looks like your audio hardware was not recognized by OSS.

If you have installed OSS just a moment ago then it may be necesary to.
to rebot the system before trying to use the device(s).

I rebooted my system several times for sure. And now my wifi stopped to autoconnect for some reason and dont see my wifi point ( but see another ones ) ( fixed this by disabling/enabling wifi device several times)

hmulti_audio should not be blacklisted. You just need to blacklist the hda driver, add-ons/kernel/drivers/bin/hda as I said in my previous message. Nothing more, nothing less.

The audio output shows as “Intel HD Audio” in media preferences, and in its settings when it is driven by opensound, you get a quite wide array of settings named “codec1.jack.black” or similar. I have all these routed to “pcm1” and that seems to work for me, with the output channel set to “Output 0 (raw)”. You may also need to raise some of the sliders.

I did what u said and there is my audio settings ( see screenshots below ) i just cant find anything u mentioned…

Help me please someone if its normal to have such menus in sound prefs…

You used my blacklist lines; where if I remove one of these three, I lose my sound. I do not know what the relationships are between these three but I have sound. With that my Audio Settings is as follows:

Audio%20Settings

Hope that helps you.

Also, when I execute ‘osstest’, here is the output:

Welcome to the Haiku shell.

~> osstest
Sound subsystem and version: OSS 4.2 (b 2017/201901281229) (0x00040100)
Platform: Haiku/x86_64 1 hrev53379 Aug 15 2019 21:33:00

*** Scanning sound adapter #-1 ***
/dev/oss/oss_hdaudio0/pcm0 (audio engine 0): HD Audio play front
Note! Device is in use (by PID 660/) but will try anyway

My device was busy due to Clementine being active (listening to my audio library).

Installed nighly build and get sound worked with OSS and this config
~> cat /boot/system/settings/packages
Package haiku {
EntryBlacklist {
add-ons/kernel/drivers/bin/hda
}
}

The only problem - my sound works only in left channel lol. Did anyone have that problem? I tried difference options in media prefs, right channel definitely enabled…

I have a similar problem with an Intel iMac from 2007. There, default hda driver used to work but at some point (long time ago) broke and only one channel outputs sound. Found no way to fix it, all my attempts to use OSS failed, unfortunately…

I do not have that problem with my rig. I have stereo and will soon check if I have 5.1 or 7.1 capabilities later.

My problem is that if I connect headphones via the jack plug, my system still sounds through the laptop speakers and headphones simultaneously. I cannot figure out how to get it to recognize only the head phones…must be a trick somewhere.