Installing Haiku on a USB

I was wondering if it’s possible to install Haiku fully on a USB.
I have a 32GB USB I want to try Haiku on real hardware so if that’s possible it would be great!

1 Like

Welcome to the community. Yes, you can boot it and run the full system from USB.

The nice thing is if you want buy a haiku compatible PC, you can bring the thumb drive into a computer store and boot it up!


it just need 4G for (system + application + swap).
you can build two partition in your usb driver.
one is be file system for installing.
the other is store data.
installer is power enough to get your idea.

1 Like

So I can just format the USB as BeFile, make a swap partition and just install Haiku on it? Is that everything? Do I need a boot partition or something else?


You don´t need a swap partition.

If you are booting on an UEFI based system you need an EFI boot partition. Details are explained here : UEFI Booting Haiku | Haiku Project


This will become impossible with secure-boot however, and the shops using BIOS password to stop the kids to render their hw unbootable, which means we wont be able to disable it.

1 Like

this is not necessary.
after installing, it will be two folder in one partition.
one is system folder, including system itself , application and swap.
the other is home folder, including user data .
i have tested: 4G is enough for normal function.
32G is so large.

Another available option is to run Haiku in a virtual machine (VM), use a USB flash drive in the VM, then install Haiku onto the flash drive. This will result in a fully working Haiku live USB without the need to have multiple partitions (besides for UEFI boot).

Personal recommendation is to use VirtualBox for this as it makes this rather easy, although there are other VM software options too.

1 Like

So I decided to use the VM method and installed haiku on a USB and it worked but only on one of my old laptops. The other ones can’t boot from it. I have a ThinkPad that I tried it on and my USB appears on the boot menu but nothing happens when I try to boot from it. And on another laptop, the USB doesn’t appear in the boot menu at all. I made a BeOS file partition and an EFI system partition. I would be very grateful if someone could help me run it on my Thinkpad.

maybe the key is Secure Boot.
you should check the BIOS setting.

I already have secure boot disabled and it doesn’t work

maybe you should list the detail.
such like what these computer model parameter or your usb-driver with “df -a”
is the system from Haiku 64-bit | Haiku Files ?
or some computer are 32bite?

This is what I get when I run df -a

here is mine.
i use the default bios setting with traditonal model .
you can compare the different.
the /boot , mine is /dev/disk/usb/0/0/0
you are /dev/disk/usb/0/0/1
maybe you can think about it.

~/Desktop> uname -a
Haiku shredder 1 hrev56814 Mar 10 2023 07:02:19 x86_64 x86_64 Haiku

~/Desktop> df -a
Mount Type Total Free Flags Device

/ rootfs 0 0 ------W
/dev devfs 0 0 ------W
/boot bfs 3.8 GiB 1.9 GiB QAM-P-W /dev/disk/usb/0/0/0
/boot/system packagefs 4.0 KiB 4.0 KiB QAM-P–
/boot/home/config packagefs 4.0 KiB 4.0 KiB QAM-P–
ramfs 0 3.5 GiB QAM-PRW

and, where is your EFI system partition?

1 Like

This command shows free space on mounted devices. It is completely useless to debug this problem.

Things to check:

  • Are you booting using BIOS or EFI? The setup for EFI requires manual steps to create an EFI system partition
  • Did you use MBR or GPT partitioning? Or nothing at all? (that’s possible with DriveSetup, but not compatible with some BIOS systems)
  • Did you create the partition table from scratch using DriveSetup, or did you use a pre existing one?
  • If using EFI (I guess you do since you mention an EFI partition), it is recommended to use GPT partition table. In that case, care must be taken to configure each partition with the proper type. The EFI partition must be of type “EFI system partition” and formatted as FAT32. The Haiku partition must be of type “Be filesystem” and formatted using BFS (these are two independant things)
  • Did you copy the content of the EFI partition from an existing working Haiku image? Or if not, what did you put in it?

So the only pc that I got it working on is using bios. I did make a EFI system partition and I followed the steps in this link to make it also boot on uefi systems:

I used a GUID partition table and I did format the efi partition using fat32 and I formatted the main partition using BFS.

1 Like

do computer find the EFI out?
try to check the File Explorer when you lauch the computer.
if not, do the UEFI setting again.
or change all computer back to the traditonal bois model .

by the way, how about using intel model instead of GUID partition table?

That could be the problem. If you want to use both UEFI and boot with MBR, you have to chose Intel partition scheme. Otherwise, when you write the Master Boot Record, you are overwriting part of partition scheme data that are stored in same place on the disk.
To resume,
for MBR boot only, use Intel partition scheme,
for UEFI boot only, you can use both partition schemes, but GPT is preferred,
for both boot, you have to use Intel partition scheme.

Another frequent problem with UEFI, is that the bootloader has wrong name or is located in wrong place. So double check cases, trailing spaces etc

1 Like

Do I need a EFI partition for MBR boot only?