Installation on a Intel i3 12100 lga 1700 fails

I tried to install Haiku 64 bits to an Intel i3 12100 system, socket LGA 1700.
The boot process runs until the icons for booting show up, but the first one on the left never gets lit and the boot process never finishes.

Isn’t this technology yet supported?

The installation is different for BIOS or UEFI firmware. The default method of installation seems to assume BIOS as the normal install. Booting on UEFI requires an additional partition configured according to a specific partition type. I’ve written the install process for UEFI on another thread.

I think he tries to boot the installer disk, which should have all necessary partitions and files in place. I think this as if the EFI partition wouldnt be there the Haiku logo wouldnt show up at all.

Maybe some of the boot-loader options can help:

1 Like

I just tried again twice.
The first icon of the boot process, the Atom, never gets colorized.
At the choice of the boot method, I choose the UEFI partitition corresponding to the USB stick that contains the Haiku image.
I start pressing space bar even before choosing that UEFI partition, but don’t get any menu to choose and disable boot options.
I was thrilled to have Haiku running on bare metal…

The motherboard is an Asrock B660M-HDV.

Edit: Could boot to options menu!

I enable safe boot, disable every other option below it, changed the screen resolution from 4K to FHD, but the boot process stops at the same place.

I guess you should maybe file a ticket on, assuming there’s not already one similar enough to your situation.

Make sure to read the docs on Reporting bugs, specially that linked “OnScreenDebugOutput” section, as it pertains to problems with Haiku not booting.

(note that pressing “Shift” instead of spamming the space-bar key to get to the boot menu, only works for BIOS/CSM/Legacy mode, and not UEFI. Need to use the spacebar for the latter, AFAIK).