How to install Haiku into my physical hard drive?

Hi! I have download a hard disk image with Haiku and tried to run it in QEMU.But it was extremely slow on my old computer (Pentium II with 256 MB RAM), and even caused my Windows to stop responding. Is it possible to install Haiku from Linux by command: dd if=haiku.img of=/dev/hda4 and then chainload it from GRUB or NT Loader?

Well, not quite.

If you dd to the entire drive, then yes, it’ll work but since you dd to a partition you’ll need to run BeOS or Haiku’s makebootable command. Otherwise you can’t boot the partition.

Check this out for some extra info:

It’s better if you can get Haiku to run natively but if you can’t then maybe these tips will help it run better in Qemu.

Try running qemu -m 96 ( Haiku itself takes about 70MB for me, so you really can’t go less than 96MB; Qemu defaults to 128MB ) - that should help a little by leaving 160MB for Linux to run in - hopefully you have a Linux swap file too.

Also, make sure kqemu is working because that’ll help speed it up.

256MB system RAM is really not enough memory to run virtual machines in :slight_smile:

Also for qemu make sure you have modprobed kqemu (only applies to linux for windows just install kqemu) or else it may not activate the acceleration layer for qemu and non of the code will run at native speed

i have a dual pentium 2 that will run haiku in qemu with only one cpu enabled in qemu and as far as i know it is not threaded but it does have 512mb ram as well… natively it runs quite well on that PC

But if dd it to flash drive? But my bios can not boot from USB media, is it possible to start bootloader and load kernel from cd disk, and then mount a flash drive as root?

Read this thread for installing Haiku to USB Flash Drive:

It also tells you how to boot from USB with PLoP Boot Manager. Doesn’t matter if your BIOS does not support USB booting.

On my Intel G33BU motherboard-based system (using a Core2Quad Q6600, (G0 “SLACR”) CPU) and 2Gb of RAM, SATA drive set to “Native”/“AHCI” (though no other drive setting (“IDE” or “Legacy”) seems to work either), while I can download Haiku (in 25 min.) and JAM Haiku (in 12 min. 30 sec.), I can’t seem to get Haiku to boot on /dev/sda2. I get nothing but a black screen after it looks like it’s trying to change resolutions or something (the brightness of the black looks like it kinda changes)

I just tried JAM again and this is what JAM says at the very end:

Creating image …
128+0 records in
128+0 records out
134217728 bytes (134 MB) copied, 2.94956 s, 45.5 MB/s
Writing boot code to “/dev/sda2” (partition offset: 20003880960 bytes, start offset = 0) …
Populating image …
Deleting old MIME database …
Installing MIME database …
Unmounting …
…updated 213 target(s)…

Looks like a perfect install to me. And I did EVERYTHING exactly the same, as I did on Athlonica, in which Haiku runs off the second partition ("/dev/sda2") perfectly! So, why is it not working? Sure, this drive is a SATA and not a UDMA133 ATA drive, like in Athlonica, but is that a deal killer?

I even tried doing a “dd” to the /dev/sda2, but to no avail… it tells me “Unable to load OS…”

So, any ideas as to what I could try?

So close and yet so far… or so it seems.

The issue may or may not be the SATA controller.

Your onboard video or something else can be causing Haiku not to boot. My onboard intel 945G video was stopping Haiku from booting. Switched to VESA & then it worked. Haiku was trying to use the intel_extreme video driver but it didn’t properly support my onboard video. Same thing might be happening to you.

Jam Haiku to your SATA partition. Go into Safe Mode and select 1024x768 resolution + use fail safe video mode.

Also helps if you turn on console debugging too to see what is going on during the boot. This will help show what is causing the hang up.

To go into Safe Mode. When you select Haiku and it starts to boot press [spacebar] a couple of times.

There are other Safe Mode options you can try out if the VESA does not work. Usually Haiku won’t boot because of:

  1. Multi-Core ( disable SMP &/or BIOS calls )
  2. Video Card ( switch to VESA driver )
  3. non-AHCI SATA controller ( use legacy mode or switch to PATA )

So, even if I never see the animated Haiku boot splash screen (which I don’t, in this case), I might still be able to access the Haiku boot menu, by pressing space? Weird… there was a little voice, in the back of my mind, that was saying something like that… but I was ignoring it, expecting that I should be seeing SOMETHING, to evidence Haiku was present/working at all.

But, here’s a question… why is it, when I would use an IDE drive (which booted Haiku perfectly on my Athlon XP 2000+ system), I would see the Haiku boot splash screen, but it would only go to the 5th icon? This is leaving everything the same, except the type of hard drive I’m using. How is this 40Gbyte SATA making things so different?

If Haiku looks like it’s booting then you can always try to get into SAFE MODE and try those options to see if they’ll work.

SATA controllers require a driver to work unless you run it in Legacy mode which lets it work without a driver ( emulates PATA ). PATA drives do not need an additional driver to function.

Haiku includes AHCI driver which I believe works. Also, you have Legacy mode available too which should work. Some info on legacy mode is here:

You may find some more info in your motherboard manual.

If you can enable console debug ( gives text output ) that’ll be more useful than trying to guess why you’re stuck at certain icons. I believe 5th icon is Chip and likely you get stuck there because of SMP and/or BIOS which can both be disabled in SAFE MODE.

You have to get console debug output or syslog to file a ticket/bug.

PS: My motherboard has PATA & non-AHCI ( Intel ) SATA. Haiku is installed onto my PATA but I can mount, read & write to SATA partitions when I set the controller to Legacy mode ( does not work in Native mode ).

Ok, after much trial and error, I have made the following discovery…

If I simply enable 1280x1024x8, I can see the Haiku splash screen. It goes as far as the “Chip” icon and will go no further. It reached exactly the same point using my IDE drive. Oddly enough, I have to manually set the video resolution/bit-depth, in the Haiku boot options, on the Intel G33BU, for the display to show ANYTHING… ever.

As a side note, I am using the built-in Intel X3100 graphics. Any BIOS settings likely to work better? Would EFI boot mode help? Disabling any of the built-in audio, ethernet, USB, etc.?

Someone else with an Intel G33BU motherboard could REALLY help, right about now. :slight_smile:

I have tried every BIOS drive setting, to no advance. “Legacy”, “Native/IDE”, or “Native/SATA” all end up at the same point on the progress bar… the “Chip” icon. Well, ok, not quite… Native/IDE resulted in only getting to the 4th icon and then KDL’ing with some page fault error message about the interrupts and a bunch of address information. Sound familiar? I can write it down, if needed.

I have also tried disabling SMP, disabling IDE DMA, enabling Fail safe graphics mode, and enabling Safe mode. Nothing changes. It simply refuses to get past the 5th icon, no matter what I do.

I don’t have the very VERY latest BIOS update for my Intel G33BU motherboard. S’pose I could install that, if you think it could help. It’s been about 7-10 months since I did a BIOS update, I figure. I’ll look into it.

8 bit color? 16 or 32 bit would be ideal.

When you select the screen resolution, you must also check off fail-safe video mode too because this tells Haiku to use VESA driver. If you just choose the resolution then Haiku may still use the intel_extreme driver & maybe why you are stuck at 8 bit color. With VESA driver you should get 16 and 32 bit. Try Fail Safe Video + 1280x1024x16.

You can try disabling almost everything in your BIOS ( except for on-board video & SATA ) and using Haiku Safe Mode Options to see if that changes anything. Hard to say what is causing the hang up without console debug info which would help pinpoint your trouble.

Stick with SATA modes that get you further along - Legacy & AHCI.

Haiku SAFE OPTIONS - Choose all of these:
use fail-safe video mode ( this switches to VESA driver )
don’t call the BIOS
disable SMP
disable APM
disable ACPI
enable on screen debug output

Try 1024x768x16 and 1280x1024x16. 16 bit color should work with VESA driver.

If the above does not work, then add Safe Mode + Disable User Add-ons.

Your console debug information would be very helpful. The icons are more for looks and give next to NO info of what the issue is. Usually best to take a snapshot and post it with a new ticket ( if it doesn’t exist ). Look at the JPG I did for this bug ( ticket #3149 ):

I take about 6 pics and choose the sharpest looking one to submit because a few will be blurry.

Once you have a photo of your console debug output. You can also add a text file of your hardware by doing “lspci -nn > devices.txt” in Linux. Take both of these and create a new ticket describing your booting issue at
Then you can update this thread with the ticket link & I’ll have a look too.

BIOS update will not hurt BUT BE SURE you know how to do it. Otherwise you could mess up the flash chip. BIOS update will help if your old BIOS is buggy or if Intel fixed certain issues with it. Could be that your BIOS or hardware is incompatible with Haiku. Motherboards from Intel use some non-standard stuff in their BIOSes which probably is causing you to be stuck at the Chip icon.

Further help requires examining your console debug output.

EDIT: added to & reworded.

[quote=Luposian]Ok, after much trial and error, I have made the following discovery…

If I simply enable 1280x1024x8, I can see the Haiku splash screen. It goes as far as the “Chip” icon and will go no further. It reached exactly the same point using my IDE drive. Oddly enough, I have to manually set the video resolution/bit-depth, in the Haiku boot options, on the Intel G33BU, for the display to show ANYTHING… ever.[/quote]

Have you checked for anything weird in the on-screen debug output?(can be selected in safe mode options)

Also Something that could really help you(like it did for me), Is to buy a serial “NULL modem” cable. You do not need to write anything down or even take photos. It just comes up in a terminal that you can just copy and paste to file.
A “NULL modem” cable costs anywhere from $2.50USD to $10USD, I picked one up that cost around $2.50USD. That is even if I am live on a island, that is five plus hours away from any Continent!

Of course you need two computers, that both have serial ports. You can read how to do so in Beos here:

My haiku box is next to my windows box, and so I have the “NULL modem” cable contecting the two. My Linux laptop does not have a serial port, so I can not tell you what software to use there. But I myself use “HyperTerminal” in Windows.

Decided to try using “Athlonica X2 5000” (a thin, tall Acer Aspire unit; totally non-upgradable (too thin to install any normal cards into it) and only one PCIe 16x slot and you’re verboten to open the case, lest you void your warranty!) by installing Ubuntu 8.10 and then installing Haiku.

Works PERFECTLY! Haiku boots up in about 15 sec. (seriously!), but… Haiku neither recognizes the built-in Ethernet nor the NetGear USB wireless dongle I tried. So, in other words… Haiku works perfectly, but… I can’t do much with it!

One thing to note, Athlonica X2 5000, can JAM Haiku in only 13 min. 30 sec.! That’s only 1 minute slower than QuadSlacker! It’s got faster RAM and a faster SATA HD bus (3.0Gbit, I think), but I figured 2 cores (Athlon X2 5000+) vs. 4 cores (Intel Core2Quad Q6600 (“G0 SLACR” revision)) would have put it noticeably behind the “QuadSlacker”, but it didn’t. Amazing AMD.

So, anyone know exactly what Ethernet chipsets Haiku supports? Any wireless ones? As much fun as I’m having being able to see Haiku running on a MUCH faster, more modern system than Athlonica, without Internet access, it’s kind of a hollow victory, if you know what I mean. :frowning:

Haiku does not have wireless support.

Provide your wired Ethernet information. Makes it easier to check.

In Linux, type “lspci -nn”; Mine is:
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)

Here’s the whole kit ‘n’ kaboodle, just in case it helps (but I bolded the part I think is what you wanted to know about):

00:00.0 RAM memory [0500]: nVidia Corporation MCP78S [GeForce 8200] Memory Controller [10de:0754] (rev a2)
00:01.0 ISA bridge [0601]: nVidia Corporation MCP78S [GeForce 8200] LPC Bridge [10de:075c] (rev a2)
00:01.1 SMBus [0c05]: nVidia Corporation MCP78S [GeForce 8200] SMBus [10de:0752] (rev a1)
00:01.2 RAM memory [0500]: nVidia Corporation MCP78S [GeForce 8200] Memory Controller [10de:0751] (rev a1)
00:01.3 Co-processor [0b40]: nVidia Corporation MCP78S [GeForce 8200] Co-Processor [10de:0753] (rev a2)
00:01.4 RAM memory [0500]: nVidia Corporation MCP78S [GeForce 8200] Memory Controller [10de:0568] (rev a1)
00:02.0 USB Controller [0c03]: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller [10de:077b] (rev a1)
00:02.1 USB Controller [0c03]: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller [10de:077c] (rev a1)
00:04.0 USB Controller [0c03]: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller [10de:077d] (rev a1)
00:04.1 USB Controller [0c03]: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller [10de:077e] (rev a1)
00:06.0 IDE interface [0101]: nVidia Corporation MCP78S [GeForce 8200] IDE [10de:0759] (rev a1)
00:07.0 Audio device [0403]: nVidia Corporation Realtek ALC1200 8-Channel High Definition Audio Codec [10de:0774] (rev a1)
00:08.0 PCI bridge [0604]: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge [10de:075a] (rev a1)
00:09.0 SATA controller [0106]: nVidia Corporation MCP78S [GeForce 8200] AHCI Controller [10de:0ad4] (rev a2)
00:0a.0 Ethernet controller [0200]: nVidia Corporation MCP78S [GeForce 8200] Ethernet [10de:0760] (rev a2)
00:0b.0 PCI bridge [0604]: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge [10de:0569] (rev a1)
00:10.0 PCI bridge [0604]: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge [10de:0778] (rev a1)
00:12.0 PCI bridge [0604]: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge [10de:075b] (rev a1)
00:13.0 PCI bridge [0604]: nVidia Corporation Device [10de:077a] (rev a1)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
02:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8200 [10de:084b] (rev a2)
04:00.0 Communication controller [0780]: Agere Systems Device [11c1:0630] (rev 01)
05:00.0 FireWire (IEEE 1394) [0c00]: VIA Technologies, Inc. Device [1106:3403]

Looks like the whole board is nVidia from top to bottom, just about. Does that make anything easier for the devs or not?

What would Haiku’s Terminal command be? Can you use Haiku to find out this same info?

The command in Haiku is listdev.

Haiku has a Nvidia nforce network driver. It only supports networking up to the MCP67 for Nvidia.

Your networking, MCP78S, is too new.

The nforce driver was last worked on Dec 2007 - about 1 year ago.

You either have to ask a developer to update the nforce driver or look for a supported PCI network card.

You can see Haiku’s nforce network support here:
and here:

Since it’s a freebsd driver, perhaps it just needs an update :slight_smile: - does the newer freebsd nfe driver support that chipset version?

From last month :slight_smile:

From Richie’s link, it looks like MCP78S has been added to FreeBSD nfe driver around 2 months ago.

I would suggest to file a ticket over at:

Stating the nforce driver does not work with your onboard LAN.

Provide lspci -nn for Ethernet only. Plus the link given by Richie. Plus the link below:;content-type=text%2Fplain

That’s the driver source and shows they’ve added:
MCP73, MCP77, MCP79

Looking up by device id we can see that MCP78S, 0x0760, is actually called MCP77 in FreeBSD’s nforce driver and is now supported.

I am fairly sure you can update the driver yourself too since you use Linux to build Haiku.

Haiku’s nforce driver uses FreeBSD driver.

You should be able to get networking going by replacing:
if_nfe.c, if_nfereg.h, if_nfevar.h

Grab them from FreeBSD here:

Replace those 3 files in Haiku which are found here:

Jam & hopefully it works out.