How to correctly install CT5880 driver from BeOS 5 in Haiku?


I’m using Haiku x86 on Athlon 64 PC with Creative Soundblaster 128 PCI soundcard.
I had downloaded the CT5880 driver for BeOS 5 and tried to install it on Haiku to make SB 128 work, but I didn’t succeeded.

The install file which is with CT5880 driver doesn’t installs properly as it is for BeOS 5.

So I did in terminal:

~/Desktop/CT5880SBPCI> cp ct5880 /system/non-packaged/add-ons/kernel/drivers/bin/

~/Desktop/CT5880SBPCI> mkdir /system/non-packaged/add-ons/kernel/drivers/dev/audio/

~/Desktop/CT5880SBPCI> mkdir /system/non-packaged/add-ons/kernel/drivers/dev/audio/old/

~/Desktop/CT5880SBPCI> ln -sf /system/non-packaged/add-ons/kernel/drivers/bin/ct5880 /system/non-packaged/add-ons/kernel/drivers/dev/audio/

~/Desktop/CT5880SBPCI> ln -sf /system/non-packaged/add-ons/kernel/drivers/bin/ct5880 /system/non-packaged/add-ons/kernel/drivers/dev/audio/old/

Then I restarted the Media services in Media, but the soundcard still isn’t shown on the list.

~/Desktop/CT5880SBPCI> tail -F /var/log/syslog

KERN: devfs: reload driver “audio” (3, 3670119)KERN: check_sense: encountered DEFERRED ERROR - bye, byeKERN: Last message repeated 4 times.Last message repeated 2 timesKERN: driver “audio” addedKERN: check_sense: encountered DEFERRED ERROR - bye, byeKERN: devfs: reload driver “audio” (3, 3670119)KERN: Could not load kernel add-on “/boot/system/non-packaged/add-ons/kernel/drivers/dev/audio”: Is a directoryKERN: check_sense: encountered DEFERRED ERROR - bye, byeKERN: Last message repeated 4 times.text/plain

I had checked the links in …~/audio/ and …~/audio/old/ and they are properly set.

But the soundcard still isn’t shown on the list in Media.

Please help me out. Thanks,

Doesn’t it work without those drivers after installing Open Sound from the Haiku Depot?

Sorry, but the PCI card wasn’t recognised by the Athlon64 PC, which is an older PC.

I just had installed Haiku on newer PC (where the card is recognized) with the CT5880 driver from BeOS 5 and it still doesn’t works.

HaikuDepot application shows an error on lunching and has to be terminated.

Is there a way to install apps and stuff from terminal (without HaikuDepot program)?

What revision are you on? It works in the latest nightly.

pkgman install opensound

pkgman gives me this:

*** Failed to find a match for “opensound”: Name not found

pkgman refresh:

Validating checksum for HaikuPorts …
Checksum error:
*** expected ’
*** 404 Not Found
*** <body bgcolor’
*** got ‘0a687e97b18e8765e148947cc9e4692cb6ecd0d4123ca74c204bdebf80833ca6’*** failed! : Bad data

It’s Haiku R1 Beta1 x86 gcc 2 hybrid anyboot, plus I’ve updated after instllation.

Repos for Haiku/R1 Beta1 has been disabled. You will need beta2 or a current nightly for pkgman to work.

Yes I already use R1 Beta 2, works.

It looks like it’s been media player issue for not playing sound (at least for audio CDs) rather than opensound driver or else… I play music from youtube and it plays perfectlly.

Can you open a bug report for that at

there are tickets for that already

I can confirm that opensound driver is working perfectly since I’m playing music from youtube and it plays fine (atm I’m using R1 Beta2 with opensound driver and soundblaster 128 PCI). It’s been the ‘Media Player’ error at least when playing Audio CD.

I also have issues when playing audio CD’s with Audacious.

Btw Audacious provides “poor-er” sound than the default MediaPlayer which is much better.

The opensound driver does the job fine for Soundblaster 128 PCI, but the original CT5880 driver from BeOS 5 is better.

It would be nice if you can add support for BeOS 5 drivers and applications. I also miss the CDPlayer application from BeOS 5 and the old mp3 encoder from BeOS 5 (not gogo or lame) and other BeOS 5 applications as well.

For apps compatibilty, you have to use 32 bits version. If you encounter a BeOS app that doesn’t run (installer or app itself) let devs know.
For drivers, I fear that it is not always possible depending of the hardware. It’s really a trying game. Also if there is a driver already handling that hardware on Haiku, you have to blacklist it before trying.

CDPlayer can be installed with pkgman install cdplayer.
mp3 encoder is supported though ffmpeg and I think we can enable it in Haiku’s ffmpeg plugin too now?
What other BeOS 5 applications do you miss?

VideoPro with DivX/3ivx and how was the one ‘MediaEncoder’ which is used for ripping cd’s to the old p3 encoder - not gogo or lame.

Managed to find VideoPro screenshot:


VideoPro is available in PulkoMandy’s software archive. Not sure how well its best known features (faster/slower playback, reverse-play) work with today’s video clips, though…

I was more of interested into (perfectly) ripping dvd’s into divx/3ivx.

That’s why we do need an (updated) HandBrake port or - why not - a more simpler Axiom-like gui…