How do I install Haiku on Macbook Pro 2010

Computer: Macbook Pro Mid 2010 model
OS: OSX Snow Leopard (Overwritten with Latest Haiku Nightly Build)

I have tried to install Haiku on my old Macbook Pro 2010 as just one partition. When I reboot the laptop after install, I see a the blinking question-mark folder icon that indicates that it can’t find a bootable volume.

What do I need to do in order to install Haiku on this machine? Do I need to use a special boot loader? What are the steps I need to perform to install Haiku on this laptop?

I cannot remember if MBP 2010 uses EFI boot or classical GPT boot. Without Apple’s bootcamp (which installs legacy BIOS and allows booting via MBR), you will need an EFI bootable haiku system (see Haiku on UEFI). Alternatively, install REfit (install to boot partition) which can boot Haiku, or install Refit to USB flash and use it as boot manager to chainload Haiku on disk. The upcoming Beta may have EFI boot loader included.


I will try to setup GPT boot on my Macbook and see if I can boot Haiku that way, if not then I think I need to skip REfit. I tried it in the past and it wasn’t for me.

UPDATE: I Setup GPT on using the Disk Utility by Formatting the Drive as MS-DOS and choosing GPT in the options. Apparently, the Haiku Installer calls it a FAT32 EFI partition. I installed Haiku on the 2nd Partition, leaving the first intact and I get the same issue, where I can’t boot an OS. Too bad.

As far as I know, all Macs use EFI. Also if you are going to use something like REfit, use REfind which is the successor to REfit.

1 Like

Yes! I have discovered this too… I don’t feel like using a custom boot loader like REfind, so I guess I am putting this one to rest. However, I am currently trying to get Haiku to work on an old Thinkpad T21 instead, which has a nice BIOS bootloader.

Hello, latest nightly hrev56533, Refind, same result ))) crash on boot

But perfectly loaded from USB flash drive :wink:

That’s an odd crash, i’ve never seen the launch_daemon bring down the system during the boot process, i realize that my reply is of no help to you, but you should get this to the Bug Tracker, it won’t get fixed otherwise.

This looks similar to a bug I reported in #13205 ([kernel] PANIC: Invalid concurrent access to page currently accessed by) – Haiku.

Did you try to boot with the disable smp option?