Hello from the new Haiku website!

Yes, as the post said, it’s almost entirely an under-the-hood change. The design and content are still the same, but everything else is different. We might change the design at some point – suggestions accepted…

from https://discuss.haiku-os.org thgere is no link to https://www.haiku-os.org/

1 Like

@waddlesplash, see also Add icon to lead you back to the main website

It works, it works! So nice to see forum replies under posts.

But please place links to forum, trac and cgit on top too.
And block with forum latest threads can find his place on page like blogs and news found.

Also I’m sending rays of rage to guys who still bind pages to fixed resolutions.
And don’t tell me that in 2017 percentages and relative measurements on page are prohibited.

This was only the first part of the migration. We have a new backend technology for the website, which makes it easier to change and improve the design.
The next step is, of course, actually changing the design.

Note that the page is not fixed anymore, it only has a maximum width, which is a nice thing for reading, but we may make it a bit larger by default.

Integrating with trac, cgit, forum, API reference, etc would be nice, but it needs deeper changes to the website organization because it conflicts a bit with the existing top-level categories (community <> forum, development <> trac + cgit, documents <> API reference, etc). It will take some time to come up with a clean solution. We also try to not move things too much in order to keep external links to our website working.

1 Like

Is there a Search field anwhere on the new site? Maybe I’m not looking properly or have the wrong browser, but I can’t find one.

There’s still a search box on the website in the same place the old one was. Looks like the search icon is broken on WebPositive – I should probably fix that. (It just uses Google now for searching.)

Hah! Actually I was using Bezilla at the time, and I definitely don’t see it there. I_do _ see it in Web+, though, and in QupZilla – and even in NetPositive!

The Ticket Updates and Mailing List tabs never populate, I get a circling arrow for ever.

Works here on the latest WebPositive, as well as Firefox on Windows. What browser are you using? Anything in the Error or Script consoles?

I’m using WebPosituive and Qupzilla on hrev 50937.

In Qupzilla"
TypeError: ‘undefined’ is not a function (evaluating ‘tab.children[0].remove()’)
activity.js:126TypeError: ‘undefined’ is not a function (evaluating ‘tab.children[0].remove()’)
activity.js:111TypeError: ‘undefined’ is not a function (evaluating ‘tab.children[0].remove()’)

In Web+It just started working for the first time.

I usually use QupZilla as web+ crashes or just stops loading pages too freequently.

The “just stop loading” part should be gone in WebPositive now (it was the same cause as the redirect problems, I think).
There are still too much crashes, I’ll have to get back to working on that (or it would be very nice if some other people had a look and I did not need to care for it all by myself, too).

I only wanted to remind your comment, because nearly four month later it is still not changed.

A bug report at dev.haiku-os.org would be more appropriate.