Having trouble creating bootable USB

I have followed the instructions to use an anyboot image copied by Etcher, but the Haiku Boot Loader says Boot volume is not valid.

I then tried to follow the instructions to create a bootable USB using DriveSetup and Installer, but getting a crash at the completion of copying the installer files. So I filed this bug:

I’ll keep exploring, but so far I am not able to get this machine up and running:

Optiplex 790 SFF Specifications:
Intel Quad Core i5-2400s 2.5Ghz CPU
8GB DDR3 Memory
320GB SATA Drive
Integrated 10/100/1000 Network Card (NIC)
USB 2.0
Integrated Video
Integrated Audio (AC97)
1 Serial Port
USB Wifi adapter

I have a copy of Haiku running in Parallels Desktop which is where I experienced the crash trying to create the bootable USB using Installer.

Until this is fixed you can disable SMAP protection in the bootloader

Apart from that VMware or VirtualBox should be fine.

Thanks for replying. Any way you could give me more information so I can learn from this? I’m brand new to all the Haiku stuff.

On the page you gave, I’m not sure what to look for as I don’t see what looks similar to the suggestion you gave.

Also, does your suggestion help with the issue of booting from the USB anyboot image or the one where trying to create a bootable USB was causing crash.

If you can give me more of an explanation I can probably learn more.

Update: I was able to boot by burning a DVD from my Mac. I’m using macOS Catalina, and was able to burn easily with just the hdiutil using the burn command. No extra software needed.

I also updated the boot order in the BIOS so that the optical drive would be chosen before the hard drive.

Now, however when it boots, just after it shows the logo and the loading icons, the screen goes all crazy and looks like some scrambled video signal.


I tried holding down shift as the computer was booting, but I was never provided any menu for choosing any custom boot options. I’ll keep reading over the web site to see if I can find the answer to this one, but if anyone knows what to do to fix this, that would be helpful.

Try hammering the SPACEBAR instead. In some configs the SHIFT key doesn’t work to enter the boot options. If that worked, you can set “Use fail-safe graphics driver” as described in the above linked “Bootloader” page of the user guide.

Indeed, on that page I gave you this option is missing for some reason, however if you manage to enter the bootloader you can find it there. This should help you to boot further from the USB.


Yes, the spacebar… that worked! I was able to get to the boot options and choose the “Use fail-safe graphics driver” which now lets me boot into the desktop. Thanks.

Also, FWIW, now that I’m running on actual hardware rather than in Parallels Desktop, I tried the Installer again to see if it would crash. It completed successfully installing to a USB-connected drive. So I guess the crash may be related to Parallels Desktop somehow. I haven’t tried other software like VMware, VirtualBox, etc.

Don’t forget this from the troubleshoot section of the Bootloader page:

  • If activating Use fail-safe graphics driver solves your troubles by falling back to VESA graphics, you can make the setting permanent by removing the #of the line #fail_safe_video_mode true in the text file /boot/home/config/settings/kernel/drivers/kernel.

That video driver problem is my fault. I fixed a bug in the intel_extreme driver and that’s the result. I’m still investigating this. I hope to have it fixed by the end of the weekend, since my laptop is also affected.


I’m looking forward to seeing the fix. Both because it would be nice to have the fix, and I’d like to take a look at the code that fixes it so I can learn more about the video drivers.

I’m excited because I was able to get the machine almost totally set up. I have it as a single boot machine into Haiku and I used one of my old Apple Airport Express in client mode so I can use my home WiFi signal served as Ethernet to the PC. It didn’t have any Wifi built in, but they sold it with a USB WiFi module. This was easier than trying to figure out how to get that to work. Although I’m half-motivated to try to see if I could get that working at some point.

The only last thing that seems to not work is the audio. I plugged in some speakers to the sound out port, but not getting sound yet. The media server keeps crashing, so I wonder if there is a bug there related to the audio device I’m using.

Other than those things, I feel I’m up and running. Now I just want to get into the code and see what I can learn and try to help out.

Fixed here: https://git.haiku-os.org/haiku/commit/?id=fadca4b173471fcb1ce40848dce4cc2adee4e681

1 Like

Crashing media_server is a known problem See https://dev.haiku-os.org/ticket/15263.
As for the audio you can try to install opensound package and reboot.

I am not sure if this is related, but I just downloaded hrev53776 and tried booting on the same hardware. As it boots on the Haiku logo screen, the progress gets to the third icon and then just hangs.

I tried also using the fail safe graphics to see if it would let it boot further, but it doesn’t.

So I’m not updating my main install yet.

See Last pkgman update have crashed the system.

Yes, there was another regression, which has been fixed yesterday (in hrev53777). Tonight build should be fine.

Thank you for the update. So far I think I have had a good experience with Haiku and the community. While it would have been a positive experience if everything worked flawlessly, it has been valuable to see what happens when things don’t. I appreciate the helpful comments and assistance in getting my install setup and working. I am pleased that in just a few short interactions I have been able to get a machine up and running and have begun to explore this project through valuable experiences. As a developer I have found that I tend to learn more when things don’t work than when they do, so I suppose this is really just like a Haiku tutorial :wink:

I look forward to checking out the update.


I’m using hrev53780 x86_64. Looks good.

Try to Reset/Restart/kill: media_addon_server then media_server processes

Result: You should hear an audible click and both server processes reappear in your running process list.
This previously resolved media_addon_server stall issues when I shutdown the laptop.

Also, you can just use the Fail-safe driver (VESA) as there are no accelerated 2D drivers (Intel) and
it works fine for most normal daily Haiku desktop use.

1 Like

So here is something strange. To be “safe” I downloaded the nightly image hrev53780 and installed to a flash drive. Then I booted from that without using the safe graphics option, and it worked fine. It was able to fully start up to the desktop. So, I went back to my main installation and used the software updater to update. I rebooted and again the graphics were distorted and I have to use the safe graphics. How this could be different from my “main” installation on the hard disk and the flash drive install? As far as I know it was the same version. Any ideas?

Try deleting the workspaces settings: home/config/settings/app_server/workspaces
It’s possible that you ended up with some invalid video configuration there.

1 Like