Hardware for build


#21

MicroSD probably won’t work if it is pcie based Haiku doesn’t have a driver for that that is finished yet, USB SD cards work though.

Does your BIOS not allow you to force USB 3 ports into 2.0 mode?


#22

Yeah I wasn’t able to boot from the microsd because of this.
And I couldn’t find any option in the Bios to force 2.0. I wonder how the rest in this thread with Intel Nuc running Haiku solved the problem.


#23

If the internal USB headers are 4pin connectors get one of these…
https://www.amazon.com/StarTech-Motherboard-4-Pin-Header-USBMBADAPT/dp/B000IV6S9S/ref=sr_1_7?ie=UTF8&qid=1539378112&sr=8-7&keywords=usb+2.0+internal+cable

Be careful of polarity…


#24

My Nuc7i3bnk has all 3.0 USB ports and a m.2 slot . This could be trouble for installing Haiku.

However there is a sata lll port on the motherboard but no room to install a SSD HD in the box it’s self.

If I install Haiku on the SSD drive from another computer and then plug into the MB of the NUC hopefully it will boot from SATAlll port. If that works I’ll then attempt to install to the m.2 drive.

How should I initialize the blank drives? MBR or GPT (GUID)

TIA


#25

MBR is most tested and fine for drives under 2TB

Installing from one install o an hdd to your ssd should work fine…


#26

Hi Glidedon,

Your NUC has internal USB 2.0 ports.
Only the external one are USB 3.0, the adapter cb88 talked about allows you to use the internal USB 2.0 ports of your NUC.

Eddy


#27

Yes, Thanks Eddy.

I ordered on of those cables just in case.

I did get Hiaku Running on my current machine!

Everything works so far. VESA mode and ignore above 4gig memory.

Thanks for everyones help so far.

Going through my old stuff I found my old BeOS 4.5 on Floppy disk from BeOS Inc !


#28

How many floppies is that?


#29

Just one floppy is all I’ve got.

And I’ve got the BeOS 5.0 CD
I’ve tried installing Gobe Productive but it just installs an empty folder.


#30

Ah I think there should be a CD that goes with that then… BeOS did use boot floppies though so I guess that is one of them.

I want to say even the CD images were just a boot floopy image + separate partition or something like that. Which is why they had to be written as a bin/cue or other format instead of ISO.


#31

Tonight I am trying to install Haiku on my NUC (a NUC6i7KYK), just bought a SATA M.2 from Samsung.
Any advise from you guys. Legacy BIOS and safe mode for the display.


#32

Please note that the above USB A cable for the internal USB 2.0 ports will NOT work with the Intel NUC computers.

You will need this one from Amazon:

Joe


#33

Should have known they’d do something like switch to a JST connector :confused:


#34

Let us know how it goes, waiting on my second cable now.


#35

OK, Im up and running on my Nuc7i3BNK.

Legay boot in BIOS. I had a little trouble getting into he BIOS because I was connected to a High resolution Monitor and the BIOS would not display, luckily I had another lower res monitor around.

I had to disable IO- APIC on boot by spacebar at Haiku splash screen. Is there a way to make this a permanent boot option?

I’ve Got sound through the headphone jack but not through HDMI.

Networking good .

Haiku installed on M.2 from external HDD via on mother board usb2 using seconed linked usb cable listed above.

Thanks for helping me along thus far.

Don


#36

Lucky you.
I have not been able to install Haiku.
Plus I do not have my keyboard working, only my mouse. I am still experimenting other solutions to make it work.


#37

have a look in home/config/settings/kernel/driver/kernel to make boot options permanent.


#38

Is your mouse plugged into one of those 3.0 ports you may have better luck using a hub off of that internal 2.0 port you got the adapter for?


#39

Yes, both of them are connected to the same usb hub (2.0) connected to a usb 3.0 port. Quite weird. And I only have one keyboard with me, I will have to borrow one from the office.


#40

No connect to the internal 2.0 port…

Someone more familiar can correct me but the USB 3 port is still using the xhci driver to talk to the USB 2 hub.