Haiku under Hyper-V: mouse scroll not working


#1

Hi, I’ve installed latest Haiku build (haiku-master-hrev52875-x86_64-anyboot) under Hyper-V.

Network is working… thanks to this guide.

I have successfully installed LibreOffice via Haiku Depot – that was a primary goal.

But the mouse wheel doesn’t work. It’s very inconvenient.

Any solution!? Help, please!


#3

This is not a problem with the mouse itself. Because mouse events are virtualized.
On the host and other guest OS mouse works fine.


#4

And on QEMU, VirtualBox, and VMware, the mouse wheel works fine. Are you sure this isn’t a Hyper-V issue?


#5

Hello Neo,

Have you fixed your mouse issue?


#6

I do not know which side the problem is: Haiku or Hyper-V.

With the standard procedure for creating a VM, the Haiku was not even loaded.

In order to install Haiku, I had to choose “Generation 1” when creating VM.
And to make the network work, I had to remove the default network adapter and add Legacy Net. Adapter.


#7

Hello Evgeny,

Thank you for asking!

No, I did not fix it.

In Haiku settings: Preferences→Mouse
Mouse type is 3-Button by default.

The middle button is even pressed when I press the wheel, but the scroll doesn’t work.


#8

Have you tried running another OS in hyper-v that is known to work with your mouse wheel? Or try a different brand of scroll mouse?


#9

In the past, I put Ubuntu and Debian. If I remember correctly, they worked fine. At least, I can not remember the inconvenience associated with the lack of scrolling. Unfortunately, the version with GUI these OSs are quite heavy for my system. And they did not take root.

Of course, a bunch of guest Windows of different versions works normally and stably, as one would expect for a hypervisor embedded in Windows host.

I didn’t even try to check the scroll with other mouse, because I understand that the VM works with emulated devices.

Now with a direct question and to clear my conscience, I checked another wireless mouse and a regular USB Mouse with a cord. It did not help – it’s not the mice issue.


#10

Perhaps there is a person on the forum who did install Haiku under Hyper-V and can clarify my question!?

There is a video with the installation process from Arnav Bhatt.

Unfortunately, it does not show the moment of working with the installed system.