Haiku screen resolution


#1

Hello
How to increase the resolution of the Haiku screen installed on the VMWare virtual machine


#2

Have you already try with Preferences>Screen?


#3

I don’t think that’s what was meant. There is no current Guest Additions available in VirtualBox for Haiku. This limits screen size to the standard vesa screen size in VirtualBox. I assume it may be similar situation in VMware.


#4

He is talking of VMWare not VirtualBox… is not similar. VMWare usually shows native resolutions, in Virtualbox you can add customize resolution see the FAQ!


#5

Works, thanks


#6

Is that a new feature of VirtualBox? I was under the impression that Guest Additions was required.


#7

No always there Custom VESA Resolutions.


#8

Seems I was fed bad info, which I was able to back up with independent research. Hate it when that happens. Duly noted. Thanks.


#9

Just be careful, 32 bits mode can lead to visual artifacts. Stay in 16 bits mode.
I do that for 4k and 3440x1440 and surface pro screen resolution.


#10

Er … what? 16 bits mode is a lot fewer colors than true-color 32-bits mode. What artifacts don’t show up in that mode?


#11

In 32 bits mode, there are ghost windows that appears on the screen. This does not happen whenever a 16 bits screenmode is selected.
So I have all my resolutions manually added to VirtualBox in 16 bits.
If anyone else faces the same problem, they can solve it easily.


#12

OK I will change to 16 bits.


#13

Where is your bugreport please? This is not expected.


#14

Thanks. Got it working. I think I had tried it before, but was unable to figure it out under Windows 8.1. I’m now running Antergos with i3wm. i3wm has issues with the fullscreen mini bar in VB. Disabling the bar in VB settings works fine.