Haiku Personal edition

Is there a way to setup Haiku in a file like BeOS PE does under windows? Also is a live cd possible, and does anyone know how to make this? I realize Haiku is far from finished, I just want to play around a bit.

Someone has already gone through the effort to create a shell script that creates a LiveCD from a compiled Haiku image (I believe it only works under BeOS/Zeta, however)



Just drop in the latest raw image (the one included is a bit old), and burn the CUE to a CD with your favorite program.

Isn’t this CD also made from a floppy image extracted from the haiku.image (to be the first session on the disc)? Don’t the floppy image bits need to be updated also? (forgive me for not knowing exactly what is on the floppy image)…

Maybe it’s just the bootloader, but I thought maybe the kernel was loaded from the floppy image directly - which you would theoretically want to keep updated with the image loaded from the second session.

The floppy image could probably be auto-generated as part of the automated build process (hint hint) - it’s just another shell script after all :wink:

BTW, that link appears to be dead.

I just made a live cd yesterday. follow this link http://paginas.terra.com.br/informatica/pauloestrela/ to get the old haiku live cd image, boot image and cue file, and then just substitute with the newest image file.

The cue file seems to just crash Nero when opening it. Anyone got this working, and how (which software)?

I’ve never had any problems using Nero or Alcohol 120. Make sure you have a raw HDD image (haiku.image) in the same folder as the cue.

Got it working with Alchol 120. Didn’t boot though (tried 3 different revisions) with pretty much the same error:

bfs: mounted “Haiku” (root node at 65536, device = /dev/disk/atapi/1/master/1)
module: search for file_cache/launch_speedup/v1 failed
could not open launch speedup!
“boot/beos/system/add-ons/kernel/cpu/generic_x86”: could not resolve symbol 'x86_check_feature’
load_module_image(/boot/beos/system/add-ons/kernel/cpu/generic_x86) failed: Symbol not found
vm_soft_fault: va 0xffff0008 not covered by area in address space
vm_soft_fault: vm_soft_fault returned error -214748783 on fault at 0xffff0008, ip 0x1045a5, write 0, user 1, thread 0x12
vm_soft_fault: sending team “/bin/sh” 0x12 SIGSEGV, ip 0x1045a5 (“runtime_loader_seg0ro” 0x45a5)
user_debug_exception_occurd(): Failed to install debugger: thread: 18: Bad port ID
error starting “/bin/sh” error = -1

Tried revision: 20299, 20328, 20336 (last two mentioned something about hangman in the error, but it was pretty much the same) :slight_smile:

Did you create a new floppy image from the haiku.image?

As I mentioned in a previous comment, failing to do so would possibly create problems as the kernel is loaded from the floppy image first AFAIK.

It’s also possible that the script isn’t copying some of the necessary files to the floppy image (as the kernel may have changed since then) - the “Symbol not found” in generic_x86 would seem to indicate that something is missing or out of sync.

Right. That seems possible. I’m not currently on BeOS/Zeta, and people here said replacing the image in the pre-made zip would do the trick. I will try to create a new boot image when I’m back in BeOS to see if that helps. Wasn’t floppy images generated at the build factory before?

I’ll maybe mention that to Sikosis if I catch him on IRC - I don’t see why it wouldn’t be possible for an unofficial boot floppy image to be created in the factory (it’s just a shell script afterall!)

The original floppy-creation script from SVN is gone I believe - which is why it’s no longer creating them.

It used to work like a week ago, but perhaps they’ve changed something that caused the old floppy image not to work anymore? I know I was having problems booting on my Athlon X2, but I figured it was from the SMP issues that were happening then.

Since then I built my own floppy image, but when used with a current build the computer just continously restarts. I assumed I had done something wrong, but maybe the new builds no longer support CD booting.

So, my suspicions were confirmed by Axel on the mailing list:


You need to re-create the floppy boot image in order to get the newer bootloader and kernel for the livecd.

Strange thing is, I’ve been making the boot floppy under Max (as a mounted Haiku volume as the source), gives no errors… everything looks peachy; the floppy image is created just fine. But when I try booting with the disc, my PC constantly resets.

Anyone else have this problem? I’d love to get Haiku running on my dual core, and using a CD is the only promising way right now.

I download latest haiku image, burn it via HaikuBootCD
and system hang up after showing haiku wallpaper. Who know how fix it?

You might want to try this one instead:

To figure out what goes wrong, hook up a serial cable, (null modem cable), to another box with a serial client application. HyperTerminal in Windows or SerialConnect in BeOS. Set it to 115200 bps baud rate, 8 data bits, 1 stop bit and no parity.

Also mentioned here:

Then copy the output and paste in a reply here.

Hi, Jonas!

I haven’t second PC to create error log. As I understand the second link consist same files to burn CD as HaikuLiveCD
I can’t mount haiku partition via Zeta because Zeta on my PC very unstabile. Now I have BeFS partition with Zeta (but I killed Zeta loader). Maybe it’s possible mix zeta Live\install CD with Haiku ?

Hello Rohan,

I think the problem is that the HaikuBootCD is outdated so when mixed with a current Haiku disk image it doesn’t work. I don’t think the Zeta Live CD would work at all for booting Haiku.

Haiku’s bootloader (at least the last-step of it) and kernel need to match to be able to boot, and they are a work in progress, meaning you have to get both from the same Haiku revision, so you can’t always match an old loader with a new kernel, as in the HaikuBootCD case, or use BeOS or Zeta parts.

If you use the LiveCD script thing, you get all necessary parts from the same Haiku revision, which removes at least that possible error. There may be some other error, possibly unsupported hardware or some such, that makes your system not boot all the way, but first you need a proper Haiku CD you know works. Try it with other computers and see if it boots anywhere. Try it in VMware in Windows, or in Bochs.

I test Haiku on virtualbox and
"Panic: Unexepted exception “General Protection Exception” occurred in kernel mode! Error code: 0x0
Welcome to kernel Debuggin Land…
Running on CPU 0 "

I’m sorry I can’t say anything about this case. I’ve never used virtualbox. :confused:

Did you use the HaikuLiveCDScript: http://www.bebits.com/app/4378 ?

Try on some real hardware, if you can, or use another hardware emulator.