Haiku os test in my mini-pc

haiku-master-hrev57451-x86_64-anyboot can not work with my hdmi device

ok,i download the iso file。
dd it into my usb flash.
choose the uefl-usb flash.
finally, it can not be supported.

Get to the Boot Loader and mark Use fail-safe graphics driver under the safe mode options, or try manually setting a resolution from Select screen resolution. Also, if available, try a different connector.
Whatever the result, see if there’s already a ticket for your graphics driver, and please open one if there’s not.

1 Like

What hardware do you have?

like this:

主机 ,工控无风扇5500U/8G内存/256G固态硬盘/双网



switch into zorin-linux, and get these information.

hdmi 1024✘600 59.8hz 7inch

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)

dmidecode -t baseboard

dmidecode 3.2

Getting SMBIOS data from sysfs.
SMBIOS 2.8 present.

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
Manufacturer: Intel
Product Name: H81U
Version: To be filled by O.E.M.
Serial Number: To be filled by O.E.M.
Asset Tag: To be filled by O.E.M.
Board is a hosting board
Board is replaceable
Location In Chassis: To be filled by O.E.M.
Chassis Handle: 0x0003
Type: Motherboard
Contained Object Handles: 0

Handle 0x0021, DMI type 10, 6 bytes
On Board Device Information
Type: Video
Status: Enabled
Description: To Be Filled By O.E.M.

Handle 0x003A, DMI type 41, 11 bytes
Onboard Device
Reference Designation: Onboard IGD
Type: Video
Status: Enabled
Type Instance: 1
Bus Address: 0000:00:02.0

Handle 0x003B, DMI type 41, 11 bytes
Onboard Device
Reference Designation: Onboard LAN
Type: Ethernet
Status: Enabled
Type Instance: 1
Bus Address: 0000:00:19.0

Handle 0x003C, DMI type 41, 11 bytes
Onboard Device
Reference Designation: Onboard 1394
Type: Other
Status: Enabled
Type Instance: 1
Bus Address: 0000:03:1c.2

So, it looks like you have a Intel Corporation HD Graphics 5500. I recommend doing the steps below:

  • Boot Haiku
  • Right before you see the bootloader screen (the row of icons on a black page), tap the space key quickly.
  • A menu should appear.
  • Choose Select safe mode optionsUse fail-safe graphics driver

This should use our “fallback” video card drivers which may work.

I think this video card is known to have trouble under Haiku:

1 Like

very interesting.
while i switch bois into VGA mode, then it is all ok.
(or,i just connect the vga line, and disconnect hdmi line, it is also ok)

so, it is the hdmi mode thing. not the Graphics card thing.
and not the UEFI thing.

now ,Touch Panel is ok, wifi is ok, Graphics card is ok.

by the way, this kind of mini pc is the most popular modle in alibaba website which is the largest Wholesale Market in China.

try again,yes it is hdmi problem.
when vga, all is ok.

1 Like

yes, i do it.
hdmi mode no problem.
but, with vesa driver mode, it only be supported with 640✘480 , 800✘600, 1024✘768, 1280✘1024.
not so correct display.

by the way, the menu of libreoffice is not so total correct with Chinese mode.
i adjust the appearance of system.
change all fonts into such like " noto sans CJK JP" or the other fonts which named " CJK".
then,no problem.
so,can this thing be the “Initial setup” with Haiku ?

Changing the fonts like that should not be required, is it only a problem in libreoffice?

If yes then open a bug report for haikuports

not only libreoffice.
but it can be fixed with this way.
just need to adjust the “appearance” of Haiku.
so, why not take these CJK fonts as the Default setting?

Those fonts erronously contain latin characters already present in noto sans, but with different renderings.

We have a font fallback system that is supposed to make setting a cjk specific font unnecesesary.

So if that doesn’t work feel free to open a bug with pictures on https://dev.haiku-os.org

It will fallback to Noto Sans CJK JP, the variant appropriate for rendering Japanese. For Chinese, you currently need to change the font manually to the Chinese one.

Unfortunately, this can’t be done using the font fallback system (not the way it is implemented currently, at least), since we need to know which language we are rendering to select the right font.

You can blame Unicode developers who invented Han Unification for this problem, and made their “universal” character encoding be language dependant for font rendering.

Yes, but they mentioned above setting it to the JP variant which fixed it, so that doesn’t seem to be the only problem.

i selete the “screensaver”.
i don’t remember which one i click.
then, the backgeound became all white.
click right button of mouse divece, and no menu.
at the same time, the application shutsown.
reboot ,then be normal.
but,when i click and run sceeensaver application.
it be again.
i try vga mode or hdmi mode or update to hrev57465, no help.

bluetooth ,
i use my phone to connect Haiku.
a message flash.
haiku can not get the phone name, then failed.
i use haiku to connect my phone, no any device display in the bluetooth.
i hope you can see the picture which upload at the other website.

1 Like

bluetooth pairing is implemented. Nothing else

So you cannot use bluetooth for file transfers, mouse, keyboard. etc. At this time

1 Like

when i adjust Resolution too much (high or low) with vga mode, it also display the same error.
so,is there the same way to strick the Resolution with hdmi mode (such like Select safe mode options →)

share the URL of my mini~pc.
please notice this, i5500u or the other cpu of these kinds miniPC, is not so new.
Yingchi Computer Store

( i find someone try very new pc with the cpu of 2022.
.“I enabled those settings in the boot menu but the only thing that happens is the Haiku logo with the icons under it like before, and the icons don’t light up (they are all grey)”
guess it, new kinds of pc have more device which can not be supportted with Haiku. if I do not mistake.

1 Like

today, i boot Haiku from my usb device ( version R1b4 hrev56578+94 ).
then i mount a portable SSD (mobile storage)(2.1 Tb size).

when read and write mode, the whole system crash into debug mode.
if only read mode, it be ok.

but this storage is empty ( format with mint-lmde-6-cinnamon-64bit, using Ext4).

i try to mount the local disk which is Ext4 with 256 Gb size, no problem.

does its size be too huge to mount?

Maybe try formatting it as ext3