Haiku on Coffee Lake motherboards?


#1

Do any of them work with Haiku?

I just get a black screen and a reboot every time I try to boot Haiku on mine (Asus Prime Z370-P).


#2

Have you tried Safe Mode? This may help in providing any additional information needed.


#3

I tried holding down Shift, it had no effect at all.


#4

I presume you are booting from USB with your BIOS set-up in Legacy Boot Mode.

I have found that one needs to hold down Shift almost as soon as Enter is pressed from a BIOS multi-boot menu.

If booting from USB is first in the order of default boot devices, then you may have to hold down Shift as soon as the BIOS splash screen disappears.

Hope this helps.


#5

The reason we use shift is that most bios keyboard test won’t complain if they see it pressed, so you can hold it even before the splash screen disappears or while still in the boot menu.

A long time ago we allowed only the spacebar but then it was hard to time things right and press it just after the bios keyboard test, but before haiku started to boot.


#6

I tried holding Shift down from even before selecting the boot device in the BIOS. Then I tried holding it down right after selecting the boot device. Nothing happens. Just a black screen and a blinking “_” (without quotes) before the PC reboots itself. The Haiku splash screen with icons doesn’t show up at all.


#7

Which version of Haiku are you trying to boot: HRev number? 32-bit or 64-bit?

Do you have some details about the BIOS like issuer and version number?

I have never encountered a situation in which the boot loader does not reach the splash screen - I don’t know how to proceed toward a possible resolution in such a case. However, answering the questions above will be necessary as a starting point for assistance.


#8

I just tried it again now with haiku-nightly-hrev51936-x86_64-anyboot.

I went into the BIOS and found this under BIOS Information:

BIOS Version 0612 x64
Build Date 03/01/2018
ME Firmware Version 11.8.50.3399

At the bottom there was also:
Version 2.17.1246 Copyright © American Megatrends, Inc.

Hopefully this helps.


#9

The BIOS may be set for Secure Boot and UEFI by default since it has been built only a few months ago.

Consult any documentation provided with the motherboard and/or Asus’s website regarding how to enable Legacy Boot.


#10

Secure Boot and UEFI are turned off. Otherwise I wouldn’t be able to boot into my non-UEFI Windows 7 and Linux installations.


#11

The 64-bit variant is not as polished/stable as the 32-bit variant. On some of the 64-bit capable systems I have, the 64-bit variant of the boot loader enters KDL while everything is fine with the 32-bit variant.

It appears that, for the time being, in order to experience Haiku with this motherboard (Asus Prime Z370-P), you will likely have to go with the 32-bit variant.


#12

The 32-bit variant doesn’t work either. I just tested it now. Same results.

I really have no idea what’s wrong. Other operating systems work. I’ve booted Linux distros off USB with this motherboard without a problem.


#13

Maybe try FreeBSD or TrueOS to check something more exotic than Linux.


#14

It looks like you are hitting a crash in the bootloader, before we have a chance to display anything. In that case the shift key won’t help. The only way to try to gather some information is to log from the serial port, if the machine has one. And even then, I’m not sure we get a lot of information logged by default.


#15

Unfortunately, it doesn’t have a serial port. So I’m doomed with this board. I’m still curious about whether there are other Coffee Lake boards that would work though.


#16

The observations of a black screen and automatic reboot would also be symptoms of a BIOS “refusing” to execute whatever is presented to it.

The downloadable Asus user manual for this motherboard does not provide much information.

From what I understand, many Linux distributions use GRUB as boot loader. And GRUB can chain load Haiku. Taking GRUB from one of the Linux distribution you know can boot on this system may provide an alternate route, albeit indirect, which could get you to Haiku booting on this system.


#17

Interesting. GRUB is kinda complex (like most of Linux), but I’ll give it a try and see. I never thought of that.


#18

So I tried adding Haiku to GRUB. I got the same result again. Here’s what I did:

Does this look correct?


#19

Yes this should work. So it looks like Haiku is not compatible with your hardware currently. The next thing to try would be getting an experimental uefi image and trying to boot that. I think you can find one somewhere on the forums


#20

Ok, I tried this image: https://keybase.pub/kallisti5/haiku-nightly-anyboot-efi.iso

I tried booting it from the BIOS. Same result. I also tried to add it to GRUB. I tried adding the efi partition and then I tried adding the BFS partition. Still same result.

One thing I noticed was that when the BIOS was set to UEFI only, I wasn’t even able to select the USB device from the BIOS menu even though it’s supposed to be a UEFI image. I also looked at the USB drive’s partition information and it says Master Boot Record instead of GUID. Maybe this helps.