Haiku on Coffee Lake motherboards?


#21

Have you got any other computer to test your images?


#22

I dug out my old Intel NUC and tried. I don’t get this issue there. Haiku has always at least showed something on all hardware I’ve owned, besides my new Asus Prime Z370-P.


#23

Then at least we know, your usb-drive is ok.

From now i see only 1 chanche: buy a serial-port card from ebay and post the boot manager output. But not here, create a ticket for this problem in trac.


#24

First check if the motherboard has a serial port header somewhere. On my PO, there is a serial port but the connector is not on the backpanel, instead they put it on a connector in the middle of the board

I’m not sure a pci express serial card can work for getting bootloader logs, because it will not be exposed at the default com port address. While we can change where the kernel looks for a serial port, it is not that easy to do forthe bootloader.

Again I first recommend trying the efi boot image, it’s more likely to work on this machine.


#25

He already tried, he wrote about it here:


#26

I have an issue with Coffee Lake too, although it eventually boots (sometimes on the first try, sometimes it has to reboot a few times). I have opened a ticket: https://dev.haiku-os.org/ticket/13991

EDIT: Can you try alpha4.1? Although it won’t boot (it doesn’t have USB3 drivers) it should display a message that it couldn’t find boot partition. In my testing it would do that reliably without restarting.


#27

I just tried Alpha 4.1. Same result.

Also about serial port, the chance at this point that I’ll find any solution is so slim that I’d rather just get some hardware in the hands of an actual dev to let them look at it. If I’m gonna buy something just for myself, I’ll buy a new motherboard that is likely to already work.


#28

Tell us your location and let’s see if we can find a dev near you, either for lending/donating hardware or for an on-site debug session.


#29

Sweden. But I think the easiest solution would be if an interested dev tells me the local price (where they live) for the board and I can donate that amount.


#30

Has anyone attempted to install/run Haiku on another Coffee Lake based system?


#31
  1. The main thing is to get the BIOS to see your boot file in a FAT-formatted GPT partition: /EFI/boot/bootx64.efi

  2. Asus Prime Z370-P, BIOS 0805

  • Secure Boot: disabled
  • PK Mgt: Unloaded (Save/backup and delete from BIOS)
  • OS Type: Other OS
  1. USB Legacy Mode (USB 2.0)

  2. SFF-type Radeon or Nvidia card (well, once you see the desktop…first things first…)

  3. Contact jessicahh on IRC…

From there you can hit the Esc key after boot screen or Shift key to see the console screen output. You’ll see the messages and hopefully the HaIku splash screen. From there, you just cross your fingers over the red rocket…


#32

I was inquiring about anyone having success in installing Haiku on any i5/i7 8th Generation system, not about a how-to-guide.

I am currently examining options to replace my current “work-horse” which is hitting 100% CPU load more than 50% of the time when surfing the web.

I could stick with a Windows 7 based system - limiting my choice to essentially a i5/i7 6th Generation system. Refurbished systems with earlier generation i5/i7 CPUS tend to have been upgraded to Windows 10 without safe keeping of the original recovery disks and/or partition. And, if I have to deal with learning another way of doing things, I would rather go with Haiku than Windows 10.


#33

Sure. Simple answer: Yes, but the Haiku drivers are not updated enough to handle some of the integrated esoteric hardware components on the latest motherboards like the Z270/Z370-series. Although I’m using the newer motherboards, I only suggest motherboards that the majority of the integrated components work reliably with minimal issue when using Haiku.


#34

I believe kallisti’s UEFI anyboot image also contained the MBR loader, so it’s quite possible you were still booting with the MBR loader, not the UEFI loader.

And your symptoms sound like you didn’t boot the UEFI loader to me. I can build a pure UEFI only image for you to try; I’ll post in a follow up reply later today.


#35

Windows 7 works fine on my Z370-P. The latest and greatest CPUs are compatible with this board. Windows 7 compatibility will eventually be a problem, but so far we’re somewhat safe. If you’re looking at buying a board, check for drivers first. You may have to slipstream some drivers into the ISO (or just install the drivers on your old PC before migrating the drive).


#36

Thank you. I’ll make sure to try your image when it’s ready.