Haiku not booting

Hi everyone, i would like to install haiku on a cheap mini PC of mine but after i select the USB flash drive (i flashed with balenaEtcher) the Haiku logo shows up but no icons “light up” under the Haiku logo, i already tried various safe mode options from the boot menu but nothing worked. The PC boots using EFI and the bios doesn’t allow me to disable EFI.

Thanks in advance!

1 Like

Using beta4 under UEFI can be done but needs an additional partition.

How could i add the additional partition?

Before thinking about partitions, are you able to boot with the usb disk until the haiku desktop , to then start the installation ?

If you cannot even boot the usb disk, your problem doesn´t lie with uefi or partitions yet.

There was mention here in the forum about problems when booting these cheap mini-pcs with display port/hdmi/vga. The guy could boot with one of the kinds, but not the others. Maybe it is worth a try. Also, have you choose VESA mode in the safe mode options ?

In case UEFI the boot
needs some action of you.

You can cut through if you have option to generate boot list with your machine.
Generally also important your PC is
32 bit

I would explain.
My Dell Precision M6700
→ boot 32 bit Haiku with BIOS mode in CSM Legacy only
The UEFI firmware of it … does not compatible with the Haiku’s
32 bit EFI bootloader. It works with only the 64 bit EFI bootloader.

→ boot 64 bit Haiku with UEFI only -
to avoid any settings in UEFI firmware related to
boot mode
→ BIOS Legacy
and affected boot order of devices in selected boot mode …

I always generate boot device list with F12.
This way I get in the list the BIOS boot device order
and after the found EFI devices can be bootable.
In this case under UEFI my USB thumb drive boot device too, as ‘haiku esp’ partition contains the Haiku EFI bootloader.
This partition is also available on Beta4 install materials as I written.

The no Icons light up can be sevceral causes, but one of it, when the
Legacy bootloader option tries to boot Haiku on an EFI firmware system as that bootloader also resides on the disk - in the beginning of the disk there is an old BIOS based program that loads the BIOS version bootloader from the BFS partition. Although it won’t work as BIOS calls won’t work on UEFI firmware if CSM had not set.

However it should not happen in your case … as no BIOS, but UEFI only, so old BIOS version program should not load by BIOS, and that does not load BIOS version bootloader.

So, anyway, to help you anyone here, you should know your machine better
if EFI bootloader you want to use.
Your selected Haiku version should fit your machine type - what type of your CPU you have ?
What modes supported ?
32, 64 bit ?
Which one you tried to boot ?
Had you set a boot order ?
Or rather generated a boot device list ?

I must say Balena Etcher may be not the best writer SW - at least for me had not worked well, but others could use it.
if you can see 2 partitions : 1 BFS (Haiku+installer) and 1 FAT32 (ESP to UEFI) on your thunbdrive - then the install media is OK for EFI - at least to boot generally.

If after you selected your device from boot list of EFI the icons does not light up, then you should set
safe options of the Haiku bootloader.
Safe option for video - which would use VESA framebuffer instead your video HW in your machine.
General safe option of the kernel - to minimize HW that has no driver available. Also can be switch off some supported options in the kernel that not built in standard way in your hardware and can cause rather errors during boot (APM, ACPI for example).

How to reach and
for the options I would suggest to read Haiku guide.


To have boot Menu you must be quick and frequently hitting the
[SPACEBAR] key just as Haiku would boot - as in case EFI bootloader the key is changed - otherwise you quickly see the bootloader splash screen … as missed the oportunity to reach the
Boot menu.

You would get quickly appear as you still do not have more updates that makes the menu appears longer, as the bootloader collects Haiku states of updates to be able to boot in a previous state before an update. These states can be many on a longer used or frequently updated system.

I hope I could help you - at least have a good start for a successful load of Haiku.

1 Like

No, i can’t boot to a desktop from the usb stick, so i didn’t install Haiku yet.
I tried using the HDMI port (i only have VGA and HDMI) but nothing changed, and yes i tried the VESA mode but it didn’t help.

Also would like to mention that even leaving the system alone for a while no kernel panics or other useful information pop up, and the system freezes entirely

The BIOS on that computer (as in the configuration utility) doesn’t allow me to turn off EFI, so i can only use EFI.

The computer has a 64-bit CPU, the Intel Atom x5-Z8350 and has 4 GB of RAM, and i think this computer would be compatible with Haiku.

I use the 64-bit image of Haiku and the USB stick does have two partitions, 1 Haiku installer partition and another small one called Haiku ESP so i think my media is ok.

And i tried multiple combinations of options from the Haiku Bootloader menu, but none of them made a difference.

1 Like

The option you can use to select in Boot menu to show syslog during boot instead of splash screen with icons and also switch off syslog paging.
Then you are able to see problem during boot, and you can take a photo about the screen where boot stops.
It can help identify the problem. You can open a ticket about or at least share here - if the text is well readable.

I enabled those settings in the boot menu but the only thing that happens is the Haiku logo with the icons under it like before, and the icons don’t light up (they are all grey)

try 32bit version.
directly daily builds iso.

1 Like


Ok, so i tried the 32 bit version of Haiku and the daily builds.

So this mini pc i have doesn’t boot 32 bit things (this is not Haiku’s fault), so when i tried both the 32 bit release of r1beta4 and a 32 bit daily build (the 32 bit nightly build i tried was hrev57499, the latest one) they didn’t boot (again, not a problem with Haiku, the mini pc just doesn’t boot 32 bit things).

The 64-bit nightly build that i tried just made a black screen, and even checking the HDMI port nothing shows up. The nightly was so messed up i couldn’t even access the boot menu (the Haiku bootloader with the safe mode options)!

And the 64-bit release of r1beta4 just made the same symptoms as my first post (just the Haiku logo with none of the icons lighting up)

So what can i do now?

The 64bit beta at least booting a bit is a good thing.

Now I’d play around with the safe mode options of the bootloader to make some icons show up.
Or even better, turn on boot-logging to the screen (instead of just the icons) to maybe identify the point where the boot hangs.

You can then do screenshots (with a mobile phone f.e.) to post them here.

Any of the safe mode/debug options do absolutely nothing. Even the boot logging to the screen.

It just shows me the Haiku logo with none of the icons lighting up.

P.S. I checked the USB stick on another computer and Haiku starts up fine

Err, what DOES the boot logging to the screen show?

1 Like

Nothing. It just shows me the Haiku logo with the icons (not lighting up) even if i select those options. And yes i waited a bit but nothing happens


Try posting the specs of the mini PC here.
Maybe somebody spots something odd.

I’d re-create the USB stick with Rufus or some dd-magic (depending on the OS used).
(I had troubles using balena-etcher with the 64bit beta ISO before)

If there is an option to enable CSM/Legacy boot mode in your BIOS (aside from EFI only), try that.

I think boot logging to the screen should show some text-mode output of the what the system is doing instead of just the icons, but maybe it hangs just “in-between” somehow…

I tried Rufus on Windows 10 to make the USB but it still doesn’t boot.

The specs are:
Intel Atom x5-Z8350
4GB of RAM
Graphics are Intel Integrated Graphics

And the BIOS doesn’t have any options for legacy booting, the BIOS is very barebones. Basically just has the boot order, time and date and a password lock for the BIOS.

Hello. Something that I read in other posts dealing with similar issues is the following:

  • Try connecting the USB drive to a different USB ports (if you have more than one available on the computer).
  • Try using a different USB drive.

Hope that this helps!

1 Like

Make sure to activate fail-safe graphics driver in the fail-safe options of the bootloader.

1 Like