Haiku not booting up


#1

i’m a linux user, but yesterday i wanted to give haiku a try and it didn’t boot, or better the screen simply stay empty after the loading screen. last year i had a laptop on where haiku was almost succesfully working but it broke and now i have a far worst pc with a very old integrated graphic card, so i assume my graphic card is not supported?

of course i am talking about the live distro as i can’t install the system, and for reference i tried beta and latest nightly…


#2

Safe mode procedure probably required.

https://www.haiku-os.org/docs/userguide/en/bootloader.html


#3

“Failsafe graphics driver” is probably the option you need (not full failsafe mode). If it work, you can make it permanent by blacklisting graphics drivers packages.


#4

ok thanks, will try that and let you know :slight_smile:


#5

tried and that solved my problem, unfortunately when i booted up haiku my usb mouse (a microsoft one) wasn’t working at all… :frowning:


#6

Try a different port, especially if it has usb3.


#7

Microsoft Mice are currently broken for some unknown reason. There’s an open ticket about this.


#8

oh, i guess i’m out if luck then…


#9

Thrift shops are full of lonely USB mice needing a new home.