Haiku in Virtualbox?

I’ve been using Haiku/Senryu in VMware Server Console for a few weeks under Ubuntu.
Now after upgrading to Hardy Heron (Ubuntu 8.04), it seems that VMware Server doesn’t work in Ubuntu now.
The preferred virtualization tool is Virtualbox.
Can anybody point me to a guide to get Haiku/Senryu working in Virtualbox?
Alternatively, would you advise me to look more to Qemu rather than Virtualbox in the absense of VMware Server?

This may help you:

Also, someone in #haiku mentioned another set of (different) instructions that might provide an easier solution for some:


I don’t think it has ever worked. I’ve been able to set up an image using a raw nightly build and VirtualBox’s included converter, but it crashes before getting to the desktop. Bug #1230: http://dev.haiku-os.org/ticket/1230

Actually, it just occurred to me that I’ve heard several people report success in VirtualBox (I don’t use it, but I do hear others in #haiku talk about it occasionally) - apparently it does work if you turn on the hardware acceleration features (requiring virtualization features in your processor apparently).

That’s all I know, sorry.

Thanks for all the replies.
Actually, the any-any update did the trick but you also need to use the hack described here.
The whole process is described <a href=http://ubuntuforums.org/showthread.php?t=770873&highlight=vmware+server>here.
Before I found how to get VMware Server working in Hardy, I had tried, albeit briefly, both Qemu and Virtualbox.
Qemu worked fine although I couldn’t get a network connection in Senryu.
On the other hand, I couldn’t get Virtualbox to work at all with Senryu.

Senryu does work in VirtualBox, if your processor supports virtualization, and you’ve enabled it in your virtual machine. See the screenshots where you download it.

Really, Vmware is the best way to go since audio, network, video & burning have support - plus it’s the quickest in my testing. To me the most important is network support, and I can’t get it to work in anything other than Vmware or Qemu.

For me, the latest version of Haiku runs fine under VirtualBox.

I use the latest version of VirtualBox for Windows x64 (the Sun xVM VirtualBox 1.6), and downloaded the RAW hdd image. Then converted it to vdi using the command “VBoxManage.exe convert haiku.image haiku.vdi”, finally created a new virtual machine with this image.
It runs if you disable the “VT-x/AMD-V” feature.

Just want to report that I am able to run Haiku w/ VirtualBox.

I am running VirtualBox 2.0 on Fedora9 on Thinkpad T60 using latest night-build disk image.

I convert the diskimage to vdi w/ command “VBoxManage convertdd haiku.image.rxxxxx haiku.vdi” and have VT-x/AMD-V virtualization turn on.


Haiku runs well for me in VirtualBox 2.0.0 even without VT-x/AMD-V enabled, which my CPU doesn’t support. It did not even boot in previous versions of VirtualBox. Cheers to Sun for improving it!

If anyone wants to use Virtual Serial Debugging via a Virtual nullmodem cable in windows, I just wrote this Tutorial.


So is there a “offical” haiku image for virtual box? I just got VB 2 and i’d love to try it out!

It seems a lot of people have reported using the vmware images (I guess VirtualBox can use these pretty much unmodified?)…

I haven’t personally tried it myself.

Latest VM Ware image 28321 works in Virtualbox 2.04 with no modifications under Mac OS X 10.5.4 (Intel C2D machine). Wow - y’all have done a fantastic job getting so far along with the Haiku effort! I am commenting from my virtual machine running perfectly under OS X and Virtualbox. So far it has been flawless!

Thanks to all who have contributed so much!

I’ve got the latest version running out-of-the-box in Virtualbox on MacOS 10.4.11, which is great! However, networking does not work for me. Can you tell me what settings you’ve used for networking? Thanks!

Hi skybum, please read the following, there’s a tip about networking under Virtual Box:


Sweet! Thank you! I’m now posting this message from within Haiku, and it’s working brilliantly.

I agree, it’s working well within VirtualBox. That’s great!

I also have the latest Haiku working in VmWare 2 under OS X 10.5.4 as well as Senryu with networking. Both seem to be very stable and quite responsive.

Got it also running nice finally some “live” feeling :slight_smile: