Godot works(ish) on the command line


#1

For those who don’t know, Godot offers functionality for handling projects and scripts from the terminal. I tested the latest HaikuDepot build this morning. I was able to run a hello world GDscript on the command line. It worked! This is the latest build available in HaikuDepot, downloaded this morning. It still reports as v2.x.x in Depot, but the binary reports 3.0.6. For those interested, check it out!


#2

Don’t construe this as a bug report. It’s more of a status announcement. I just tested the most recent build of Godot that just updated in the Depot. While the editor is still borked, I’m getting some functionality finally at the command line. I tested a simple hello world GDscript this morning. That worked. This evening I copied over a super simple game project that I made for testing purposes from another platform. It is basically a root node with a player(KineticBody2D with the godot logo as a sprite.) No collisions set up. Just the player and the capability to move left or right. I added to the movement a print statement to display whether left or right arrow is being pressed. While the godot window does come up and display, it remains blank. No splash. No player. Just blank. That’s fine, remember those print statements? They display in the terminal when I press the respective key. This will continue just fine until I kill the program. I see this as big news for Godot on Haiku. Previous builds wouldn’t even load a basic script. WooooHooooo!!!