Gambas on Haiku?

I used to hear there is a port of Gambas to the Haiku platform but I don’t know about the current status of it. Is it in a working state now?

For anyone doesn’t know Gambas is just another dialect of the BASIC language.

http://gambas.sourceforge.net/en/main.html

The only working “visual basic” clone I know of is YAB (Yet Another BASIC),
that might be worth a look if thats what you are looking for.
I havent used it extensively,
so I dont know how close it is to Gambas syntax though
You need the Besly repo activated to see it in the package manager

It says in the GamBas wiki that support for Haiku was added in version 3.9 but there’s no package for it in HaikuDepot at the moment. It might build from source right out of the box but I suspect it requires Qt5.

1 Like

@hean8209

Hello and welcome,

the lastet Version of Yab is in haikudepot under haikuports. Yab 1.8 is under development.

Yab isn’t a clone of visual basic. It is a port of yabasic. Yab is more then yabasic, there are gui Elements in yab.

Take a look to yab.besly.de and or besly.de. you can find tutorials and examples about yab programing. There is always a forum yab.orgfree.com.

Write us, if you need help.
Regards lorglas

3 Likes

Yes I started a port long ago. Didn’t touch it in a while though. I can probably post the patches somewhere.

Update: I cloned the repository on GitLab.com, branched to the latest tag release: 3.15.2 and installed autoconf, automake and libtool from HaikuDepot. The re-config script ran and generated a configure script. I made a build directory and ran configure from it. It generated all of the Makefile scripts. It couldn’t find all the depencies that I had installed like libSDL2 but I wasn’t expecting miracles. I ran the makefile as a parallel build. After one warning it tried to make a .so file but couldn’t find libdl (the library base for shared objects on Linux) and stopped. It seems close to building but there’s no guarantee that making shared objects is the only blocker. I tried anyway.

1 Like

Ah so maybe I did upstream it? Or maybe someone redid the work… wouldn’t be the first time…

You can safely remove -ldl from the linker flags.

Since there are dozens of makefiles and all of them auto-generated by configure, I thought I would do the easy thing and make an empty dl.a file using GCC and ar. I tried putting it in ~/config/non-packaged/lib/ but GCC couldn’t find it still. How do I find out what the ld path is?

You need to put it in ~/config/non-packaged/develop/lib/ (notice the extra “develop”)

Thanks! I’ll try it!

Sorry, it’s still not finding it.

Or patch configure(.ac)

Configure.ac was modular and included references from each plugin separately.

I make patch for build, but it crash on start for now

Thanks for trying.

screenshot38

7 Likes

Excellent! :slight_smile:

Back in BeOS days, I was all about C++/BeBook and never explored other tools. Last night I tried Yab-IDE and PAINLESS! I love it. Mostly I’ll be putting GUIs on my console apps. Just the right thing!

Welcome to the world of yab. If you have problems, let us know.

My biggest shell tool gui in yab are imagemagickGUI

3 Likes