Force updating fresh Haiku install kinda breaks it

so I installed Haiku R1/Beta 3 from the download page on VirtualBox and right after install I tried updating, cause you know, cool to have new features… and then I see this O_O

so yeah, I wanted to see what happens if I pick the solution 1, so I checked it for all the options… actually no, I think I updated by terminal, but it also had option 1. anyway, after the update, the terminal was broken and I wanted to fix it, so I tried to upgrade to nightly, changing repo in HaikuDepot as it wasn’t the terminal and still seemed to work

and it just couldn’t

I reinstalled the os and changed the repo to master one before updating, updated and it worked, so yeah, don’t use solution 1, at least on fresh installs

Yes, unfortunately things break quite badly as we are somewhere near releasing beta4, but it isn’t quite there yet, due to last minute bugs and bugfixes. But some software already depends on pre-releases of beta4.

We should really fix this before the next beta so we can provide a smooth and safe upgrade path for everyone.

Until then you can wait a few days/weeks, or maybe try switching to nightly builds


Nothing too bad, I have used nightly on my main PC before and it seemed stable enough - not really an issue for me, generally I had nowhere near as many issues with Haiku as I had with Linux, but I can imagine someone just trying the OS and having a bad time, so I’ll rather let you know if you didn’t


The terminal being broken is very strange. It appears you somehow managed to install a package that needs a version with the new locale handling (implemented in the development branch after beta3) but still have beta3 packages installed. Not sure how that could have happened, the package manager should have prevented you from doing that…


Looks like I ran into the same issue:

Beta3 is being phased out…

  1. pkgman list-repos

Haiku Repo (r1beta4-current):

Try this procedure (if needed):

  1. pkgman drop-repo Haiku
  2. pkgman add-repo
  3. pkgman drop-repo HaikuPorts
  4. pkgman add-repo

Then try:

  • pkgman full-sync
1 Like