Finally got Haiku installed on my Dell Latitude 2120


#1

Hello everyone!

First post here, but I had a couple of snags while I was installing it. Hopefully this post might help someone else trying to get this laptop working with Haiku.

First, while booting through a USB, the boot loader would stop on the rocket ship and just freeze. I had to do some digging, but I found that you could go into safe-mode along with other options while holding the to shift key before it begins to load. I had to use the “Use fail-safe graphics driver” in order to be a
ble install the OS. After installing I reboot with no boot loader options ticked. Unfortunately, the rocket didn’t take off again. I restarted the latop, and enabled the fail-safe graghics again. This time I had to make it permanent. To do that I opened the terminal and went to

/boot/home/config/settings/kernel/drivers

to edit the config file where i removed the # before the option.

So here I am with an installed Haiku laptop, but with no Wireless Networking. A wired connection works, but I’ve already installed the firmwares from the daily tasks, but it’s not picking up the card. I really want to contnue using this little netbook to run Haiku. Does anyone have a suggestion for a good compatible and cheap NIC that I can swap into here?

I’m looking to help this community and I’m eager to see how this OS turns out. I think it has great potential. Thank you!


#2

Perhaps look into if using a different card is possible with your laptop before shelling out money for one. Even if you found one that will work with Haiku, does not mean it will work in your laptop. I’m not certain about your laptop, but my HP Inspiron G6 will only successfully POST with HP approved NIC or none at all. I tried several that I had laying around that work with Haiku in other laptops. In this machine, they all fail to boot before the BIOS is loaded. So I’m stuck with using ethernet wired to a relay router to my main WiFi router. I haven’t let this stop me from enjoying Haiku. Create a ticket in Trac (dev.haiku-os.org) with your Laptop and NIC model, and attach your syslog. That way the devs know to work on it when they can.


#3

Hmm thank you for the input. I’ll give it a shot. I also have a Asus U56E that I put it on, but I’m having some networking issues on there too. I might just keep using the Asus since it runs Haiku a lot snappier than the Dell.


#4

What issues are you having with the Asus?


#5

Basically, I’m unable to connect to my wireless network. I’m picking up the SSID and all, but when I enter my password it doesn’t ever issue me anything. I’ve tried it through ifconfig, but It still doesn’t work. I’m close to the router and I’ve even changed it’s channel.