Call for testers - intel_extreme driver

Hi there,

If you are watching the git logs a bit, you may have noticed that lately I worked on the intel_extreme driver a bit. I think I fixed a lot of the remaining problems for the devices really supported by it (i845 up to SandyBridge). This should provide a sane base for refactoring of the driver and adding new features: hardware cursor, dual screen support, and handling of the more recent hardware which is still quite incomplete.

However, I want to make sure the driver is really stable as it is now, before I start working on these. So, if you happen to have any hardware around using these, I would appreciate if you could test it and report any issues you find.

Please use hrev53787 or later (tomorrow’s nightly build will be fine)

Here is a list of things to try:

  • Booting Haiku should get to the desktop using the native resolution
  • GLTeapot works and the FPS matches the screen refresh rate (it should be 60fps in most cases)
  • Booting with VGA/DVI/… display connected should result in working display on it, and a clone on the LVDS panel. If your BIOS allows you to switch between different displays before booting an OS, try the different cases there (bios on VGA, bios on internal display, etc)
  • Changing video modes and colordepth works
  • Switching workspaces works

If you hit problems, please open bugreports at Include the PCI ID of the video card and a syslog, as well as a description of the problem (and pictures if needed)

Thanks for your help!


So no dice on Ivy Bridge like i7-3840QM?

You can try as well, and if you have problems and didn’t open a bugreport about it, it’s a good time to do so. I just want to make sure I have solved all issues on the previous generations of cards before I start adding the new ones.

Hello! I had an old Dell 11z notebook that was affected by the regression introduced recently. I will test it again and report any issues.

Thank you! :+1:

Nice to know I have a:

Intel corporation Mobile 945GSE Express Integrated Graphics Controller

to test, maybe it will be effected too?! At least I hope so…
btw. it is working quite fine atm (hrev. 53783 32bit) expect there is a black screen with GLTeapot right now.

2 different resolution (nativ on both) is still not possible, right?

How it should work? If separate desktop on each display than it is not yet supported in app_server.

Not yet. App_server somewhat supports it, if you have an old radeon 7000 or 9250 that driver somehow manages it. However, what’s missing is making the BScreen API actually work, alerts pop in the middle of one screen and not in between them, etc.

Few progress has been made on this sofar becâse without amodern driverfor it, no one uses the feature so there is no motivation to improve on it.

I’ll repeat myself: if you have any of these problems, make a bugreport . Not a reply here, a bugreport.


I have tried hrev53790. No synchronization. #15448

I have tried tonight’s build on an Intel Mobile 4 integrated chipset. It now boots to the desktop without using safemode. Everything appears to be stable. I get 60FPS with GLTeapot, though there does appear to be a mask around the mouse cursor when I move the cursor over the GLTeapot window.

Superlative work, sir. No bugs = no bug report. Many thanks.


Hi Sabex,
I see that you had opened a bugreport earlier:
Can it be closed then?

Thanks for updating the status.

1 Like

Tested w/hrev53790 x86_64 (Intel HD Graphics, Ironlake):
If Default settings (no resolution changes): No Haiku splash screen, black screen output

In boot menu, if default screen resolution set (not default).
Result: Haiku splash screen - all icons light up. Monitor display ‘resets’. Black screen (no blue desktop).

EDID info displayed properly. More monitor sync tinkering needed…


NOTE: If monitor disconnected before bootup, wait 3-5 minutes for full bootup, reconnected monitor. Got blue desktop (success!). So, seems like a monitor re-sync issue during boot.

  1. GLTeapot works fine at 59-60 FPS.
  2. Brightness scale in preferences!
  3. Enhancements: multimonitor (2 displays, some legacy desktops are VGA/DVI-D (dual-link)
  4. Screen resolutions selectable: 640x350x8 through 1920x1200x32.
1 Like

8086:0a16 - Haswell:

  • desktop ok
  • GLTeapot: ok
  • brightness: ok
  • external screen: can’t test right now
  • videomodes and color depth: ok
1 Like

Hello! Works well here too! The video problem with the Dell 11z was fixed.

  • Works at native resolution.
  • Brightness control works ok.
  • GLTeapot at 59 FPS

Thanks for the good work :+1:

1 Like

Hi @PulkoMandy. Thanks a lot for your work on the Intel driver front (among other things)!

Is HD Graphics 5500 supported with your current fixes? This is on my Lenovo Thinkpad T450s.

I upgraded to latest nightly and rebooted but it still shows VESA. After that I thought about asking :slight_smile:

Did you blacklist the driver? If not, that means your hardware isn’t handled yet by the driver and you’re safe, my changes won’t break things for you :smiley:

I suppose you mean blacklisting the Intel driver. No I never did it. From the start my card was not detected and VESA driver was used. So I conclude correctly that is not supported yet :frowning:
Actually I mainly miss the brightness adjustment you gain when a graphics card is detected…
Now I am adjusting the brightness when I startup the computer during BIOS password state. Luckily I found that tip in the forum some time ago :slight_smile:

Tested my Sager W110ER w/ 3610QM … and got a black screen. VESA works in failsafe mode. Bug report filed.

On my Sandybridge Mobile GT2+ Thinkpad X220 laptop I was having the same resolution problems as un_spacyar with stretched display. After updating the display shows correctly in 1366x768 again.

60 FPS teapot and external display mirroring is working. booting with vga works.