Blender and gallium on haiku


#81

OMG, it isn’t the latest! How did i found this old version??? Lemme retry at night with the latest one.
Sorry guys :slight_smile:

Edit: Oh, yeah, googling “blender source” lists the blender archive as first result.


#82

Lol! OK, I’m not a complete idiot :slight_smile: I did spend a lot of time trying to build with cmake, but have the PYTHON_LIBS not found. I know very little about haikuporter, not quite enough to set up the environment to run the recipe. So I get the above error. Thanks for looking at this. It will be a great tool when we get it working.

With 8-core CPUs becoming standard release in a few months, this will be fun to work with even without GPU accleration.


#83

Happy?

http://chunk.io/f/fb9b4a0097a445f4ae2719496af962ed
http://chunk.io/f/604155b4788c4f7d8412cecb045d8f01

I’ll update the current HaikuPorts recipe to the latest one.
GHOST requires SDL2, i built without it, but it cannot draw the UI, so i had to enable the SDL2 output.
It starts in full-screen, tried to resize, but it doesn’t works. So i cannot give you any nice Haiku with Blender screenshot.

The SDL2 output not realible, as it forgets to update the window content. MAybe it requires extra patching. Somebody can look into it.

You can find my preliminary recipe and patchset here: https://github.com/haikuports/haikuports/pull/1130
Any test would be really appreciated. (BTW, i built it outside of HaikuPorter, so the recipe haven’t tested yet, i suppose it is broken right now, will fix later)

The Haiku backend for GHOST should be updated to eliminate the SDL from the requires…

Edit: My latest recipe compiles fine on my laptop. If somebody interested, can test it already.


#84

Guau! then the render dont work yet? is very cool see haiku running blender, should be more in the future ill guess, there are Godot engine and it can be compiled for haiku easily, the two software can start to give more gaming in haiku . that is good for atract more people and kids.


#85

you try it with soft mesa?


#86

cosmogatokat: i don’t work on this stuff anymore as i have no interest in Blender. Somebody can continue the porting work of course.
Yes, it is with soft measa. The normal 3d object rendering (displaying 3d elements in viewport) works, hovewer a bit glitchy, the cycles render engine disabled for now.


#87

I cant get it work or i dont understand how haikuporter work, can you help me with this please?

haikuporter blender
Checking if any package-infos need to be updated …
Looking for stale dependency-infos …
Warning: skipping blender-2.78a, as it is broken on the target architecture.
Error: No version of blender can be built


#88

Try with “haikuporter blender_x86”


#89

~/Downloads/blender-2.78a> haikuporter blender
Checking if any package-infos need to be updated …
Looking for stale dependency-infos …
Warning: skipping blender-2.78a, as it is broken on the target architecture.
Error: No version of blender can be built

and

~/Downloads/blender-2.78a> haikuporter blender_x86
Checking if any package-infos need to be updated …
Looking for stale dependency-infos …
Error: blender_x86 not found in repository


#90

Blender is dependent on python3, which can’t be used atm on x86_gcc2h: you have to use x86_gcc5 or x86_64.


#91

then should i install a gcc5 version or with the hibrid i can do something? D:


#92

It is a very cruel news for me.


#93

You need to configure haikuporter to enable “secondary architecture” in the file haikuports.conf to allow building packages ending in _x86.
It should be possible to build python3_x86, too, I think?


#94

Is working :slight_smile:


#95

mmm but it

updating dependency infos of zstd_x86-1.1.2
updating dependency infos of zziplib_x86-0.13.59
Looking for stale dependency-infos …
Warning: skipping blender_x86-2.78a, as it is unsupported on the target architecture.
Error: No version of blender_x86 can be built


#96

~/haikuports> haikuporter blender
Checking if any package-infos need to be updated …
Looking for stale dependency-infos …
Warning: skipping blender-2.78a, as it is broken on the target architecture.
Error: No version of blender can be built

D:


#97

hp blender_x86 --get-dependencies


#98

haikuporter -S -j4 --get-dependencies --no-source-packages blender-2.78a
Checking if any package-infos need to be updated …
Looking for stale dependency-infos …
Warning: Port blender-2.78a is broken on this architecture.
Continue (y/n + enter)? y
ok
Checking if package dependencies need to be updated …

media-gfx::blender-2.78a
/boot/home/haikuports/media-gfx/blender/blender-2.78a.recipe

Skipping download of source for blender-2.78a.tar.gz
Skipping checksum validation of blender-2.78a.tar.gz
Skipping unpack of blender-2.78a.tar.gz
Skipping patchset for blender-2.78a.tar.gz
Cleaning up temporary directories …
‘NoneType’ object is not iterable

:confused:


#99

See in the recipe:

ARCHITECTURES="!x86_gcc2 !x86 x86_64"

Did you adjusted it? IT was tested on x86_64 only.


#100

haikuporter blender-2.78a --get-dependencies
Checking if any package-infos need to be updated …
updating dependency infos of blender-2.78a
blender_x86_gcc2-2.78a is still marked as unsupported on target architecture
Looking for stale dependency-infos …
Checking if package dependencies need to be updated …
updating dependency infos of blender-2.78a

media-gfx::blender-2.78a
/boot/home/haikuports/media-gfx/blender/blender-2.78a.recipe

Skipping download of source for blender-2.78a.tar.gz
Skipping checksum validation of blender-2.78a.tar.gz
Skipping unpack of blender-2.78a.tar.gz
Skipping patchset for blender-2.78a.tar.gz
Cleaning up temporary directories …
Fetching package for devel:libglew …
Fetching package for devel:libgomp …
*** Failed to find a match for “devel:libgomp”: Name not found
Error: unable to resolve required packages for build for blender-2.78a
Error: dependency-infos:
Error: /boot/home/haikuports/repository/blender-2.78a.DependencyInfo
Error: /boot/home/haikuports/repository/blender_source-2.78a.DependencyInfo
Error: repositories:
Error: [u’/boot/home/haikuports/packages’, ‘/boot/system/packages’]
Error:
~>

I removed the ! but … this happen.