Blender 3.3.1 for Haiku

Blender 3.3.1 for Haiku

  • Tested on Haiku hrev56524.

Care to explain how you got it working ? I am missing How´s the speed?


Related info on speed:

Works fine on Haiku. Just install “blender3” if using a x64 processor - once the package is shown as available using HaikuDepot (or pkgman).

To fix the issue:

  1. Reinstall opensubdiv 3.4.3-1.

Still wont work here! weird

As always the devil is always in the details. Check again what he wrote:

And the Forumtopic mentions “Blender 3.3.1

But there is only “Blender 3.0.1” in the Depot, which is as you have seen is broken.

So he said you supposed to wait till the 3.3.1 lands in the depot. When it will happen thats a different question.

The recipe got merged 5 days ago, but it did not made into the repository, as the builder got lost. Reason for that is unknown to me.

There is also an open pull request, with the " blender: disabled x86" title, but this also switches from LLVM9 to 12, no idea why.

It would be nice if it would be not necessary to do a detective-work to understand @cocobean, but he is a cryptic one.

TLDR: create an issue at HaikuPorts to kick the builder on.


There are no x86 builds of Blender3 - that is why that build was disabled.

No, i meant the reason for the LLVM version jump is not clear and it is not mentioned in the PR title.

Test this for now: Blender 3.3.1 ← x64 Haiku package


Keep in mind the consequences of downloading and installing packages from random sources.

1 Like

Tried, no go.

Welcome to the Haiku shell.

~> /boot/system/apps/Blender3/Blender
runtime_loader: /boot/system/apps/Blender3/Blender: Could not resolve symbol ‘_ZN10OpenSubdiv6v3_4_33Sdc6Crease18SHARPNESS_INFINITEE’
resolve symbol “_ZN10OpenSubdiv6v3_4_33Sdc6Crease18SHARPNESS_INFINITEE” returned: -2147478780
runtime_loader: /boot/system/apps/Blender3/Blender: Troubles relocating: Symbol not found

  1. pkgman full-sync
  2. Redownload the blender3 package.
  3. Retest.
1 Like

sad for me! Iamout

Work fine.


beware of stuff from Facebook etc

Really, you got it working. Did exactly as described above. No go !


1 Like

doesn’t blender use vulkan now ? the vulkan software renderer is way better than the opengl last benchmarks I saw, I’d se3 if x512 has any input, he’s worked 3d Accel

1 Like

yeah, they’ll drag their feet