BeOS App Can't Open Serial Port

Hello all,

Let me preface this by saying that I’m totally new to Haiku and BeOS, and I know next to nothing about software development

Here’s my problem:
I’m trying to run some old BeOS (v5.0.3) software that interfaces with some old audio hardware that I have. The software is meant to communicate with the hardware through an rs232 serial connection. While the application will open in Haiku, I get an error telling me that it is unable to open the serial port to communicate with the hardware.
I’d like to know if there’s anything I can do to get this app working in Haiku. I tried running BeOS 5.0.3 in VirtualBox and I do not get the same error. However, after configuring VirtualBox to use serial ports, the app freezes shortly after opening.

Any help with this is greatly appreciated,

What’s the name of the app you’re trying to run?

It’s CueStation 2.5
Not sure if I’m allowed to share the executable here?
If not, it can be obtained relatively easily by contacting Meyer Sound customer support (which is how I got it).

Likely this is some problem in the pc_serial driver (it’s really not so robust, and there are other issues like this.) @mmu_man may know something.

So is this an issue with VirtualBox then?
I’m currently running it on MacOS, would it be worth trying on a Windows machine? Or would that not make a difference?

I suppose you disabled serial debug output… although IIRC the driver shouldn’t publish the port which is used for that.
You could try to enable debugging the driver, it seems creating pc_serial driver settings file, with debug_output true would work, cf.

Well, before digging so deep in debugging, there are a few simpler things to check:

  1. Open a terminal and type “ls /dev/ports”. Do you see the serial ports there?
  2. Can you use the ports in SerialConnect?

In Haiku, the first serial port is by default used for kernel debugging, so you will need to disable that if you have only one built-in serial port (this is not a problem for USB to serial adapters)

Hey guys,
Just wanted to pop in and say I haven’t abandoned my own thread! I am, however, out of town until next weekend and won’t be able to try any of your suggestions until I’m back home. Thanks for your help, I’ll report back once I get a chance to play with it more.

To answer your questions:

1- when I enter that into terminal, it returns “pc_serial0”

2- I don’t really know what serialconnect is supposed to do, so I’m not sure what you mean by “can you use the ports…” In the Connection dropdown, I can select pc_serial0 but nothing happens after I select it.

In SerialConnect you can type things and they will be sent to the serial port. And anything received from the serial port will be printed. How far you can go with this depends on what device you have connected to the port and wether you know the protocol to use for communicating with them.

Interesting… I am unable to type in the serialconnect window. I see a solid white cursor but nothing happens when I type.

Just tried reselecting the serial port in the Connection menu and got a kernel panic. image

As I said, what you type is sent to the serial port. If the device connected there does not reply, you won’t see anything.

So I shouldn’t see anything as I’m typing?

I’ve been given permission (by Meyer Sound) to share the executable for CueStation 2.5.
If anybody feels like downloading this and giving it a shot, let me know if you have any luck!

standard warning about linking binaries

Sorry for being a total noob, but what’s the best (safest?) way to share this file?

It’s fine to share as is. It’s just a reminder for other people to not download and run arbitrary binaries from anywhere on the Internet on their machines.

Hello, heffree!

I tested “CueStation 2.5” software you shared. I ran it under BeOS 5 using COM2 serial port, the OS is installed in a physical computer (dual Intel Pentium 3).

This computer has two serial ports, so I connected COM1 and COM2 with a serial null modem cable and also execute “SerialConnect” software (it is included with BeOS, it is a terminal like software) to view and capture the raw data that “CueStation 2.5” send through the cable from
COM2 to COM1 port.

So, when I Send parameters or change faders positions, press buttons, I could see data in “SerialConnect” software, it is working fine. I could also change communications parameters (serial port number, baud rate, parity, etc).

I hope my explanation is clear enough, I could make a short video if you need it.

Could you build an old PC (older than Pentium 4 is better, for example: Pentium 3, Pentium 2, AMD K6-2, Pentium, etc) and install BeOS 5, to successfully communicate with your audio equipment?

Do not worry to find a supported video card, you could run it in grayscale, we could also help you to make the BeOS installation.

Well it’s good to know there’s nothing wrong with the executable, thanks for testing that out! Unfortunately, the oldest machines I have hanging around are Pentium 4, and only one of them (a Dell poweredge 400sc) has two com ports. Would there be any hope of getting Be installed on this machine? Or should I try to get a hold of something older?