BeOS 5...set date past 2010?


#1

Hi All,

BeOS fan here that got Haiku running yesterday on a VMWare Fusion VM…loving it so far but I can’t wait for cifsmount to happen.

My question about the date was driven by cifsmount…I finally got cifsmount to work on BeOS 5 to mount a drive on my Lubuntu machine. After mounting, I noticed that all fo the files on that share had their create and modify date changed to 2010. That seemed odd. I went back to BeOS and it appears that one cannot set the year in Time Preference past 2010. The next option is 1965.

Is anyone aware of a fix for this?

THx!

Von


#2

Check here https://discuss.haiku-os.org/t/is-the-beos-revision-5-out-of-time-beos-inc-beos-revision-5-and-dates-commencing-january-1-2011/


#3

I had a copy of the Time preference recompiled for PowerPC that had a bug fix. It was on bebits, but probably doesn’t exist anymore. IIRC. I can see if I can obtain an Intel one, but I have no means of testing it.

Edit: yeah, it was here: Time pref for PowerPC


#4

@Diver THx for this link. After reading through it and trying it on my Intel BeOS 5.0.3 install I found that these commands worked:

$ /bin/date -s 05/10/2019
Fri May 10 00:00:00 PDT 2019
$ date
Fri May 10 00:00:10 PDT 2019
$ /bin/date -s 23:24:25
Fri May 10 23:24:25 PDT 2019

And seemed to keep the time/date after a restart. I now need to get the timezone figured out as every file in mounted Lubuntu director had their modified dated changed to a date ~6 hours in the future.


#5

@memsom…thx for this. I poked around on wayback for the Intel version and could not find it as that is what I need and would like to try.


#6

I don’t think there was ever an Intel version made.


#7

i just uploaded CClock to the bebytes repository.


#8

Thanks for this. I installed it and after finding the setting to get it to English all is well. THx again!!