BadWolf Web Browser

I saw that some folks were having issues with Epiphany web browser having to use a lot of memory to run smoothly so I thought I’d take a look at some other options for a browser using WebkitGtk. and I thought I’d try Badwolf.

Badwolf’s a minimal privacy oriented web browser that uses Wayland or X that currently in development. It literally takes less than 5 minutes to compile and build. The only thing I’d point out if anyone is interested, would be after running config, you need to edit the config.mk file to edit the Cflags to -FPIC and also add the correct prefixes and such.

6 Likes

Hi. Cool. And does the browser has less memory footprint?

I’m currently using an HP Elite 8300 from 2011 timeframe. I do plan on getting out one of my old OptiPlex’s to test further. Currently, I’m able to run with Haiku managing virtual memory with no issues. as compared to needing to use quite a bit to run epiphany comfortably.

2 Likes

it doesn’t matter which browser is used, it only matters which web engine is used. the problems with excessive memory usage in webkit-gtk have already been solved.

7 Likes

Is there an updated release with the fix?

already published a few days ago in my LOTE repo

3 Likes

7 Likes

Any chance to get them in the main repo before/around the new beta?

You mean the 2.28.2 version? it still crashes for me? i’ll try to clean up the cache later and see, i’m far from a haiku machine.
BTW how did you enable the bookmark toolbar?

Bookmark toolbar? Where? Epiphany has a bookmark manager button only. This button is displayed if you bookmark at least one site by pressing a star in the address bar.

2 Likes

Memory fixed in 2.38.2-2

3 Likes

I plan to do it tomorrow

10 Likes

Oh,my mistake, i took the tab toolbar for a bookmark one :grinning:

What did you exactly do to get it to build? i tried and ./configure failed with the following error

Checking: pkg-config --atleast-version=2.32.0 webkit2gtk-4.1 ... FAIL

And yes i do have webkitgtk_devel installed, tried with master and version 1.2.2.

Hi khallebal,

I installed initially both libsoup2 and libsoup3 devel packages, however I just removed libsoup2 and it ran config

removed image as previous image would cause possible confusion

1 Like

Very good to hear about BadWolf browser. I had not heard of this web browser before. I quickly compiled BadWolf on Linux and tested it out. It runs very good on Linux. I just have to compile and test on Haiku next to compare and test. :slightly_smiling_face:

I am also happy to see and hear that Epiphany is working better now. I ran Epiphany early on and was taking up memory badly on Haiku. Over 3GB in use + 400MB swap for one browser tab. :grimacing: I can’t wait to update and try out Epiphany again.

Thanks.

2 Likes

That didn’t help, well i suppose i’m missing a dependency of a dependency that webkitgtk uses but i don’t know which one that is, so…i give up for now, if someone finds what it is please guve a call to my office .:smile:

I have BadWolf working on Haiku and I am testing it out right now. :grinning:

Try:
pkg-config webkit2gtk-4.1 --print-requires

And check with:
pkg-config webkit2gtk-4.1 --print-errors

I only used --print-errors and that showed me the missing libraries one after the other that I had to install.

This should not be necessary, the package probably don’t define a dependency. If the package comes from HaikuPorts, open an issue at the github page.

I had made a quick hpkg package without listing deps. so I did a fresh nightly install, and did the following:

Downloaded the packages required for epiphany, plus wayland_devel gtk3_devel and libsoup3_devel (probably don’t need the devel pkgs, however I was trying to recall exactly what pkgs I had installed when built)

The hpkg installed fine