Asus KCMA-D8 booting

So. I just bought a KCMA-D8 this week. Dual opteron 4332 HE, 6 cores each, and 32GB ram. Haiku is the only operating system that I have been successful at installing, booting and running so far… I’ve tried Debian. I’ve tried FreeBSD. Only Haiku works.


That’s extremely weird… what were the issues with Debian?

I’ll have to give my KGPE-D16 another shot before the beta releases. Normally Haiku has a lot of issues with dual socket systems so people should not assume it will just work.

1 Like

Came to full stop here:


Both of my X7DCL-i boards ran Haiku fine. Dual Xeon, at 4 cores each. That was most of last year until last week when those boards finally gave up the ghost.

As far as the KCMA-D8, I had to install BootMan to get the BIOS to recognize a bootable partition. Just installing or running makebootable failed to get the BIOS to recognize a bootable partition. Then I let it go through the splash screen several times, which it would automatically restart after the last icon lit up. Then I held the space bar as the BIOS handed control over to the OS and then everything just started working. Only there was no boot options menu. This dance seems repeatable, as I’ve reinstalled a couple times because I’m actually trying to get Linux or FreeBSD installed so I can use this box as a video and audio workstation. Each time I reinstalled Haiku after getting fed up with OtherOS™, I went through this dance and Haiku will boot and reboot and run as it should. Come to think of it those supermicro boards I had to do the same thing to.

What graphics is that displaying on by the way… sometimes if you have an embedded display controller for this can get crossed up and your display will switch over to it or just plain get screwed up you might want to try disabling anything like that in the BIOS.

1 Like

I’m running on a Radeon HD5450. No issues with the display that I can tell. I have the embedded VGA disabled. As far as Linux is concerned, the issue seems to be APIC related. Shutting that off in BIOS doesn’t help. In Haiku, the only problem I’ve had so far was getting things booting. The above proceedure did the trick.

Peopple keep misunderstanding what makebootable does. What you needed was probably writembr instead.

The boot process with a BIOS is in two steps:

  1. The BIOS reads the first sector of the disk, and runs whatever code is there. For Haiku there are 3 ways you can get code there: installing bootman, using writembr, or creating a new MBR partition table from DriveSetup.
  2. That code finds a partition to boot and loads the first sector of the partition. BootMan lets you chose which partition, while writembr and the code installed by DriveSetup will just pick the partition currently marked active. You can mark a partition active in DriveSetup when you create it.

The code in 1 can be replaced with many other versions: the one from Windows, from FreeBSD, or another boot manager such as Plop or Smart Boot Manager. The code in 2 is specific to Haiku and is the one that is installed by makebootable (but also by Installer, so you should never need makebootable if you use Installer).


Thanks for the explanation. That makes sense.