Anyboot-CD - PANIC: did not found any boot partitions on all my systems?


#1

Hello there.
Last days i wanted to give the 64Bit Version of Haiku a try. Therefore i burned a anyboot-CD and tried to boot for install.
No success -> landing in the KDL. For further testing i then used the 32bit hybrid anyboot-CD (hrev51366) and tried it on all my systems (2 Desktops, 2 Notebooks) all with the same negativ (see subject) result.
The latest offered live-CD with hrev47380 boots all my 4 systems and on all was Haiku successfully installed bevor in that way. I must say, the all are older machines with normal msdos-partitioning with a mbr. The bootmanager was GAG 4.10 and all installed linux distributions were forced to install grub in the root/install partition and not the mbr. It seems to me that the bootloader code of the anyboot-CD works somewhat different to that of the live-CDs?
I then tested a little bit more to found out that difference. That are the steps i’ve done:

  • I deleted the haiku partition with a gparted live-CD => no success

  • I uninstalled GAG 4.10 with his own bootcd and made one linux partion activ and bootable. The system then boots that system correct. The Haiku anyboot-cd fails with the same PANIC than before.

  • I created a grub-install in the mbr with a bootcd called Rescatux and the linux systems are all bootable from that menu. Haiku still fails.

In the end, i first had success in deleting all on the disk with gparted by creating a new partition-table. Then the anyboot-CD boots as normal. But that is not really a solution - i think:slight_smile:

IMHO from the viewpoint of a potential unexperienced new user of Haiku would it not be better to offer a live-CD (instead/additional of the raw-image) as in hrev47380? raw-images are very limited for end users: Lack of space on the created mini-partiton and a not expandable bfs filesystem.

That should not be a critique but only a appeal.
Has anybody an idea, what lets anyboot-CD fail on all my systems?

Greetings
Joerg.


#2

Before you create a partition, you have to select in the menu of the Disk Setup, which you starts from the installer, “Disk” -> “Initialize” -> “GUI Partion Map…” and then write in this new section a Be Filesystem partion.
And after you have installed the system, you have to click in the menu of the installer “Tool” -> "Write boot sector to haiku"
if I remember right.


#3

http://besly.de/menu/search/archiv/sys/haiku_installation_eng.html

Like this description, the Haiku Guides should descript this too.

Give it a try


#4

Thank you for your hints, but you have completely misunderstood me. I have successfully installed Haiku many many times, but in the past always with the offered live/installer-CD. With the comfortable command “pkgman update” i never had the need to install from scratch again. But no i want to try the Haiku 64Bit version but there were no longer live-CDs offered.

In my last question [quote=“joergn_1, post:1, topic:6066”]
Has anybody an idea, what lets anyboot-CD fail on all my systems?
[/quote]

you will see my real problem. So please read my original post carefully, to see where my problem was.


#5

If you think it is an issue for next buolds or a bug report, you should add this into the bug tracker.
I use not the any boot, because tey are more for USB stick iirc. The 64bit version is not the best build today to test Haiku, because it is too yound and not ready.

Lelldorin


#6

The anyboot image is usable both as a live CD and as an USB stick image. After a few years of running that succesfully, we have decided that maintaining the old CD-only images was not needed anymore.

Problems with the live CD should not be related to the partition layout of your hard drives (or even the presence of an hard drive - it’s supposed to be a Live CD).

What I think happens is that something in your disk drive layout confused Haiku, to the point that it failed to find even its own data on the CD. But, it is hard to say without a syslog. You could capture one from the serial port, if the machine has one, or otherwise, use on-screen debug and take pictures.

This problem may not be related to the differences between anyboot and old-style bootable CDs. It could be one of many other changes in the last few years of development, and I think a likely cause is changes in the SATA driver which could simply make it not play well with your CD drive or SATA controller.

The raw images are not meant to be used directly, but as yet another option to install haiku. You can write the image to an USB stick partition, run makebootable on it, and then use that to install the system on a more permanent place. We keep them small so it is faster to copy them to a disk, no need for copying a whole GB of data.

As for BFS resizing, there was a GSoC project about it a few years ago but I don’t know what happened to that code.


#7

PulkoMandy.

Thank you for your comprehensive answer. This part:

let me remember, that on all those systems in the past was a version of ecomstation (the successor of OS/2) installed. This OS has a strange behavior to interpret partition layouts and wrote some information elsewhere with its own version of a LVM (Logical Volume Manager). I’m quite sure, that was the thing which haiku could not handle very well. It seems no one else has such problems and therefore it is not worth to investigate deeper.
Installation is always possible for those systems with the last live-CD and thanks to “pkgman update” keep Haiku up to date.

Again thanks a lot.


#8

If Haiku does not start up, unplug all you UBS connections (only keyboard and mouse). I have some times problems to start up haiku and the usb driver.


#9

I had to bring up this thread again -sorry for that - but i think it is pretty import in view of potentially new users. At that time in my former post my assumption in the end was, that all problems had to do with the IBM interpretation of LVM but that was not the case:
On the weekend i again decided to do a test with 64bit Haiku and therefore i reactivated my much sold Levono Thinkpad R60. I deleted all partitions, the partition-table and the mbr and wrote all zeros to the disk like factory-fresh.
But with the -at that time- latest hrev of the anyboot-CD i failed again with that kernel-PANIC (see subject) at the boot step of mounting disk.
The indirect way with dd-ing a boot usb-stick from haiku with the raw-image, i could install the well known way - also with the latest ISO.
IMHO it must be a code difference between anyboot-CD, raw-image and the cd-rom-ISO.
If i would be a new user and want to try out haiku and fail, i don’t want to bother to register to post on the forum and possibly make a fool on oneself.

I think the Thinkpad has a rs232 port, but how can i capture a syslog. Are there any docu about that?


Newest Haiku x86_64 crashes
#10

I experience the same problem with R1 beta anyboot.

Tried to boot on 2 PCs already as follows:

  • PC1 (no DVD drive)
    - 64bit version on USB stick
  • PC2 (with DVD drive):
    • 64bit version on USB stick
    • 64bit version on DVD
    • 32bit version on DVD

Same result every time: Kernel panic : did not find any boot partitions.
Screen picture below : corresponds to 64bit on bootable USB stick

USB stick was created from Linux according to procedure described here.

thumbnail


#11

I have similar problem with my Lenovo Thinkpad e460. I created the USB-stick in Windows and get the same boot partition notification. Tried the safe boot but still no. Are there any solutions?


#12

I have duplicated this issue on my new laptop. You get a KDL on boot at the ‘disk’ icon, so you never see drive setup. This is booting from a USB stick having followed the process with Etcher, using Legacy OS mode, no secure boot. Even wiping all windows UEFI partitions and replacing with a single ext2 doesn’t work.

I suspect my issue is one of not having marked the partition with the correct flags in gparted. This is not documented in any Haiku documentation.

On a vm, the iso boots and you can use drive setup to do this. On physical hardware, it KDLs before it boots from the USB drive, preventing any easy set up.

Then, the lack of effective documentation on gparted means you’re left with trial and error.

I plan on spending some time on this tonight. If (no, when damnit!) I find an answer, I’ll post here.

I will report bugs when I’ve got full information.


#13

I used Etcher on Windows 7 Desktop PC (no uefi?), to create the bootable usb for the 64bit beta, and every time i booted from the USB, i got the message you mentioned but on the safe menu.

It brought the line on a black screen, then autoshow safe menu, let me choose usb partition ‘Haiku’ and boot from there.

I booted that, created a new Haiku partition with 10gb and reboot, having the same procedure but showing 2 partitions to select from.


The same drive just plugged in my laptop (UEFI, secure boot disabled), didnt want to boot. As not even detecing a boot partition or whatever (no KDL, just nothing to boot from in the USB).

However, using Etcher in 64bit linux laptop and x86_gcc2 “almost beta RC1” iso i was able to boot directly using the same usb drive in the laptop :thinking:

Maybe it’s some unexpected Windows Etcher flashing?


#14

It could well be some Windows Etcher 64 bit weirdness. I’ve also flashed an Ubuntu image to that drive, and have experienced issues too.


#15

I am having the same issue. I burned a DVD from the beta1 ISO, but when booting from it I get a
“PANIC: did not find any boot partitions!”

I verified the ISO is correct and the disk was verified during burning, so I doubt that’s a problem.

The only other storage device in the target system, besides the DVD drive, is a single hard drive which had already been zeroed out then partitioned using Linux. This is the intended destination drive but I don’t even get far enough to do anything with it.

Please help.


#16

I am also having the same problem with the x64 anyboot image. System is Intel NUC i5.

Downloaded and flashed a usb drive with the anyboot image as specified using etcher. Reboot NUC to run from the usb drive and receive the “PANIC: did not find any boot partitions!” message.

Have followed this process a half dozen times with the same error each time. Would appreciate an alternate installation method or a new version of the anyboot image that will work with flash drives.


#17

It works with all flashdrives, but not with every USB controller, i fear. Try to set it to USB2 mode in BIOs if it possible.


#18

If your hard drive is empty, you can just dd the haiku image from live Linux to the disk. Use /dev/sdx instead of /dev/sdxY as target.


#19

Hi extrowerk,

I rewrote my USB thumb drive and was able to boot partially. I have no idea why the boot process completed this time and not others. However, there is a new problem with the display graphics. See the photo below.

My system details are as follows:
Intel NUC6i5SYB
Processor i5-6260U
Graphics Iris Graphics 540
In Linux Mint 19 XFCE, the display resolution is 1920X1200.

I have already checked my BIOS configuration and there is no option for setting the display resolution.

Thoughts?


#20

You could probably try the fail-safe video mode. See https://www.haiku-os.org/guides/troubleshooting#blank-or-corrupted-screen-after-booting
Also https://www.haiku-os.org/docs/userguide/en/bootloader.html