Alt key not working in emacs

This is a correct observation.

And this is exactly what am i talking about.

I tried it again now.
Ctrl-x Ctrl-+ works fine,but whenever I navigate to somewhere else,it is reset to unreadable.
I can’t change it permanently with Set Default Font as that always throws errors,no matter what I try: set-font-attribute: Font not available: …

Confirm. While Emacs on Windows also doesn’t save the font size for me, on Haiku it clearly doesn’t discover installed fonts and uses X11 font specification. I doubt Haiku works this way. Probably it is too early to expect more :smiley:


Seems I actually made the patch public at one point… You can probably reuse create_bfont_from_font_spec from that at least.

1 Like

Looks nice. The default machine/user name “shredder” makes me laugh every time though… :laughing:

Spacemacs works much better with the new version of emacs. Havent poked around much yet, but there seems to be some bugs (like treeview)


1 Like

Oh, is this some kind of insider joke?
What’s the origin of it?
It’s like the Walter naming of the hrevs in the about panel? :grinning:
It caught my eye the moment I looked at the previous screenshots that Alpopa showed. I’m used to see it in Dukto identifying my Haiku machines.
BTW, how can it be changed?
(Well, if the origin is interesting I may consider keeping it :nerd_face:)

Hostname in network preflet?

I’m honestly not sure what its significance is; perhaps one of the devs could tell more…

Do’h! So evident… :sweat:
It’s clear that I havn’t search for it too hard.
Thank you for pointing me to it, extrowerk.

Will be interesting to know, even if it was just some developer having fun, i love this kind of details and “easter eggs”, so to speak. They give a lot of personality to a system.
Meanwhile, I have given my machines some boring but identifyable machine names.
Oh well…
I’ll need to find some cool ones to make justice to a system like Haiku.

1 Like

That is a bug; is your system configured in any special manner? Specifically, what is the value of `be_fixed_font->Size ()’?

In any case, these bugs should be sent by e-mail to You can use the built-in command `M-x report-emacs-bug RET’ to send such a report. (M-x here means to press the Command key on your keyboard alongside the key “x”.)

On the contrary: it does discover fonts. menu-set-font is simply the wrong command, you should either set it through Custom or using `set-frame-font’.

I would not have considered a font driver that does not discover installed fonts acceptable for inclusion in Emacs.

1 Like

Please describe in detail the bug with the Spacemacs treeview feature, and preferably report it to the bug tracker, so I can fix it.

This is not a fixed value, it is set in the appearence preferences (and the smallest value it allows iirc is 8.0F)

I know that it’s not a fixed value, it’s the value Emacs relies on for determining the default font size. So either we have a bug somewhere, or nipos has misconfigured his system.

If he managed to misconfigure that somehow that would be a haiku bug too, so that would be interesting indeed.

I have no idea how I could get the be_fixed_font->Size() value but I checked the Appearance settings as that should have the same values.
Fixed width font is set to Noto Sans Mono with size 12.
I also tried setting the font to Droid Sans Mono or the size to 13,that doesn’t make any difference in Emacs.
I still run the build from November 22,was anything fixed in the meantime so that I should try a newer one?

Great work with the port of Emacs (its feels more or less complete). I played around a bit last week, but never got the ccls (LSP) server to work. I’m really new to emacs therefore I use spacemacs for now before I learn how to do my own configuration.

So I added c/c++ support in my config, but as soon as it switched to major-mode the lsp-server tried to start but crashed. lsp-diagnostic / std-error showed me that I didnt have any json support. Donwloaded some janson_source/lib, run reconfigure and recompiled. No more json error, but it wouldn’t start. Dont remember the exact error but I can paste it here later if I can reproduce.

I guess you are really good with emacs, could you maybe help out with lsp/auto-complete configuration that works with Be/Haiku API and C/C++?

Tried to download “all-the-icons–install-fonts” but it doesnt work on Haiku.

Emacs on my old i3 (iMac) ruining Haiku is much faster than on my MBP (2013, with i7 CPU). Startup time is about 2 seconds less on Haiku. (almost the same packages)

1 Like

Sadly, I have no idea about LSP servers. I found Semantic to somewhat work with Haiku after a some prodding, so I might work on it in a bit.

all-the-icons isn’t part of Emacs, and the directory it installs fonts into doesn’t work on Haiku. You should raise an issue with their developers.

1 Like

Yes, please update and see if the problem is fixed there.

It doesn’t compile anymore.

You should run “make bootstrap”: make clean only removes binaries and other not-very-important things.