Youtube doesn't play any videos

I just downloaded nightly, hrev54575, the newest 64bit nightly available. It boots fine. But it will not play youtube videos… at all… none. “Your browser does not currently recognize any of the video formats available.” I have tried 36 different videos. HD, SD, old videos, new videos… nothing… I thought WebPositive was past this stage?

To be clear. I am running from the bootable USB. I do not want to go through the hassle of installing it unless it can at least work with the sites I use most.

If I’m not wrong, the problem was caused by some changes in the Youtube site. Unfortunately, Youtube is some kind of “moving target”.

In the meantime, I would suggest you to use QMPlay2 to open youtube links. It also has a nice little search function for youtube videos.

As a positive side-effect, you will avoid to see all the toxic comments that flood youtube… :rofl:

Well at least I’m not crazy, well not that crazy. It did work before… Anyway. I haven’t installed it to HD so I just wait a while and try again later.

Youtube still works with Web+ on Haiku R1B2. Best to use the tested R1/beta release track for
certain tasks.


Alternatively, you can also ‘pkgman install otter_browser’ as that browser still works with Youtube videos on the nightly and stable tracks.

See: Youtube Playback

Can I assume that the devs are working on the problem? I apricate the suggestions. But, I just don’t intend to install Haiku to my HD and have to start working around this type of issue. I am content to wait for the problem to be resolved. Hopefully it won’t be too, too long.

AFAIK. You can use the Haiku R1B2 Live USB/Live DVD ‘boot to desktop’ versus HD installs.

Did you open a bugreport about it or look if there is already one?

I did a search and found something about youtube. At least I think it was. If you need me to put in a report, I will be more than happy to. Would there be any specific information that would be helpful?

Unless, you don’t have place on your USB stick, you can install packages via HaikuDepot as well as if you have installed on disk.

Otter browser has stopped playing youtube aswell. I get this message in all videos I try to play with Otter on youtube: “An error occurred. Please try again later.” It does not matter haw much later. I still get the same. I am using Otter 1.0.81 weekly 333 and QT 5.15.1 in Haku hrev54732 x86_64

I use Haiku R1 Beta2 nightlies 64bit, 20GB RAM

youtube does not work with Web+ but with Otter it is working for me!
Have to try again now…
Dooble is working too!

Check here:
and html test here:

Maybe mask Otter in network preferences as other Browser?
No idea sorry all.

I can’t play Youtube videos on WebPositive either

No youtube video in Otter or Web Positive in recent nightly 64bit.


Otter plays Web+ not…

I was fighting to find a browser which could play youtube (or videos, otter is crashing on youtube and on the play button doesn’t do anything.

I managed to play youtube music and video using SMTube (which is in haikudepots). It’s somehow a bit jaggy (music replay is not perfect), but it’s working at least. ? Is that supposed to be funny? I suggest you keep your racist slurs to yourself and refrain from using it here.

Apologies are in order. It’s a regular site.