yab-IDE 2.2.8 not working?

Lately I’ve been amusing myself by converting an old BASIC game to Python. Then I remembered about Yab and thought I could bring it over to there and, also, not have to rely on the terminal.

I tried to run yab-IDE (from HaikuDepot), but it just popped up the splash screen and then disappeared. I downloaded the source and ran it again and it stops at an error:

mkdir: cannot create directory '/boot/home/yab_work': File or Directory already exists
mkdir: cannot create directory '/boot/home/config/settings/yab': File or Directory already exists
cp: cannot stat './BuildFactory': No such file or directory
---Error in ./yab-IDE.yab, line 3874: invalid stream: 0 (can handle only streams from 1 to 124)
---Dump: sub set_up_BuildFactory() called in ./yab-IDE.yab,981
---Dump: sub OpenMainWindow() called in ./yab-IDE.yab,102
---Error: Program stopped due to an error
---Program done, press RETURN---

The line 3874 in question is: while(not eof(#handle)) and I’ve included the surrounding lines for context:

DataDir$=trim$(system$(“finddir B_USER_DIRECTORY”))
x=system(“mkdir “+DataDir$+”/yab_work”)
system(“mkdir ~/config/settings/yab”)
y=system(“ls “+DataDir$+”/yab_work/BuildFactory > /dev/null”)
y=y+system(“ls “+DataDir$+”/yab_work/Programs > /dev/null”)
system(“cp -ur “+ideDir$+“BuildFactory “+DataDir$+”/yab_work”)

	while(not eof(#handle))  // This is line 3874
		input #handle a$ 
		system("cp -u "+ideDir$+"src/"+a$+" "+DataDir$+"/yab_work/BuildFactory/"+a$)
	end while
close handle
system("cp -ur "+ideDir$+"src/column "+DataDir$+"/yab_work/BuildFactory")

Is there an easy way to fix this? Is it something wrong with my setup that I can change?

Thanks in advance.

I Sound this bug too and report it.

I solve this, copy the yab-ide folder to non-packaged and move the src folder into the src folder (crazy) and copy the buildfactory folder here too.

I does not understand who change the ide in the past to have the source two times in there, that is totally Nonsense.

I know that we, besly, working on repackaging the yab components, but it is not available jet

1 Like

Thanks. I’ll see what I can do with it to get it working again.

Is this on a 64 bit haiku system? I have not seen the issue on my system (32 bit)

Where did you report the error? I do not see this issues on GitHub.

Yep, it is 64-bit.

Here 32 bit, clean haiku install. You can not get the error on a long running one ;-).

Better test a new package to install on a fresh test haiku installation

I just removed everything that uses yab and then re-installed yab-IDE and got the error. interestingly, if I open a terminal and cd /boot/system/apps/yab-IDE then run yab-IDE from the command line, it opens and works just fine. Must be something about yab-IDE’s ability to find the working directory.

1 Like

Please contact lorglas, he is reworking the packages.

The Problem in the IDE is the BuildFactory.

I looking for the BUG and i will solved it.

Regards Lorglas

1 Like

So, the new packages are online and available in haikudepot.
If you found some issue please use the bug tracker on trac.besly.de.
Not all of my found issue implemented, but noted.

Have fun with the new-IDE.

regards lorglas