Wrong default font in Calligra and Trojita

In the mail app Trojita I cannot read all Html Mails. Some are okay and some, i.e. from Amazon have a wrong font. The app even starts with a wrong font. Here is a screenshot:
Trojita-Font

I got the same font in Calligra words as default font:
Calligra-Words-Font
In the menu there is the font Noto Sans Display.
Calligra-Font

In Calligra I can just use another font. But in trojita I cannot change the font.

What can I do?
Haiku beta 2 with all updates.

Do you have some custom fonts installed?

There were some problems with font fallback till few months ago. This was fixed on nightlies but IIRC the fix on beta was only partial.
It looks like anquietas or one of the ancient fonts provided by themes_stargates package. Did you install it?

Qt doesn’t use our font fallback code, so this is likely unrelated.

No, I only use Haiku with the preinstalled default fonts. I didn’t install any font.
Okay. I’ll wait till the beta 3 is released.
For my mail I use the default Haiku Mail service. I only tried Trojita and it looks pretty good.
I’m crawling through Haiku Depot and test some apps. :smiley:

1 Like

The font that is shown is not part of the Haiku distribution, so it must come from somewhere else. Check your font directories (system/non-packaged/data/fonts, system/data/fonts, and the equivalents in home/config), someone might have installed this strange font for you?

Thanks for your advice. I found the Ancient font in system/data/fonts.

ancient-font

I couldn’t delete it because it is readonly. I never installed it. It must be come with an other app installation. But I only installed apps from Haiku depot.

The strange thing is that I booted Haiku with a prior state (two days ago). The font is not in the system/data/fonts folder. I only rebooted to the actual state from 5 minutes ago and the font is of course in the folder. But - Calligra and Trojita now use the normal font! Not the Ancient one. I don’t know what happened here.
The issue is solved but I’d really understand, how.

As I said above, it is part a of themes_stargate package.

1 Like

“listattr -l <file>” tells you where that file comes from, if the file attributes set up correctly.
Also please spend 5 min to scroll trough the user guide, to learn about the file-system, package management and read only files.

You can get this information from Tracker as well: right click -> get info -> attributes

1 Like

The Stargate font/theme is installed as part of the “default themes package” used with the theme manager.

Yes, it is from Stargate.

=> /system/data/fonts/ttfonts> listattr -l Ancient0.52.TTF
File: Ancient0.52.TTF
Type Size Name Contents
. -------------------------------------------------------------------------------
Text 26 “SYS:PACKAGE” themes_stargate-1.0~git-3
Text 35 “SYS:PACKAGE_FILE” themes_stargate-1.0~git-3-any.hpkg
MIME String 29 “BEOS:TYPE” application/x-vnd.Be-symlink

Stargate-Font

It is right. I installed the Theme Manager to get a more dark theme for my laptop display which comes with much brightness.
I booted the system a few minutes ago again and evrything is fine with the font. Trojita and Calligra work normal. But it is nice to know.

2 Likes

Is there any good reason to have an unreadable font packaged in the Depot? Should we just drop it?

2 Likes

Thanks for this! Looked like Otter suffered also from this (when using drop-down menus to upload images to imgbb) :clap:

1 Like

A very good question! Another question is why should such a font exist at all, let alone be supplied with a Haiku app.

If you go to a Stargate fan convention, you will probably find someone able to read that. It’s like to klingon language in Star Trek universe.
More seriously, at origin the stargate themes were available freely for Win9x.
They are a kind of proof of concept showing that ThemeManager can import such themes.
I think that they are also the most complete and aside of that little font problem among the most usable available as package.

I think that we really need more usable themes so we can drop those not working. But for that, ThemeManager should handle ControlLook and also all colours…

1 Like

I think Blender its preferences are unreadable of wrong font too…

1 Like

The question why a font that was never selected in Appearances or the app is becoming used. If it is only by being installed, we will end with problems with other fonts. Dotsies for example,won’t be a lot more readable.

4 Likes

I just installed the ThemeManager and a theme pack from Github. Stargate was now in the Theme Manager, but I never installed Stargate as a theme. I only looked for the theme in the preview. I stayed with the Haiki default theme.

I don’t know if this has an impact but apparently these are the only fonts in /boot/system/data/fonts/ttfonts that are not files but symlinks.
Real files are located in /boot/system/data/UIThemes/Stargate_Atlantis/Stargate Atlantis Base/SGA Fonts.
Maybe we shouldn’t have text files (cantarel.readme, lohit.readme, ubuntu_font_family.readme … ) either in the different fonts folders.
Another anomaly is that some otf fonts (FiraCode, IBMPlex … ) are identified as OpenDocument Formula Template.