WPA: join at startup

Hi, i’ve installed the latest nigltly of Haiku with wpa_supplicant, i can join to my network, but at every startup i have to join manually. There is a way to join automatically, for example by setting a config file?


Hi Giova84,

I’m not sure that the following actually works, please keep us posted if it does for you.

Create a text file /boot/common/settings/network/wireless_network and edit it to contain:

network SSID-name-of-the-network {
 authentication wep|wpa|wpa2
 password Your-password-string

Don’t use any quotes (""), so no spaces in name/password allowed. In the second line you choose either “wep” or “wpa” or “wpa2”.

As I said, I’m not sure it’s really working, but that’s how it was originally planned. Though, Michael said at last BeGeistert he just chose an easy password and enters that on every boot-up. Doesn’t inspire much confidence, now does it? :slight_smile:


Hi Humdinger,

I set the wireless_network config file with my own options (the password and network name are simples, without spaces), but unfortunately doesn’t work for me!

At this point, if there are no other solution i’ll wait for the progress of wpa supplicant :slight_smile:



I’m a newbie but if you see here: http://www.haiku-os.org/guides/daily-tasks/wireless

Automatically connecting to a wireless network

To make your system connect to a given SSID at each boot automatically, you can specify your wireless networks and passwords in /boot/common/settings/network/wireless_networks with the following format:

network wifitopia {
password mypassword

So, it is not “wireless_network” but “wireless_networks” (you missed the final “s”)


I corrected the filename, but still not join automatically.
But a thing is changed: if i look in network preference inside the deskbar’s applet, i can notice that Haiku try to connect to my network (DLINK - the name of my net - is selected), but the wifi still say “configuring”. Before the correction, after few second he said “no link”.


I solved in a very simple way.

I made a script like this:

ifconfig /dev/net/atheroswifi/0 join MYNET MYPASS

then i put this script in /boot/home/config/boot/launch. Now wifi join automatically!

I still have problem with wpa_supplicant.

I have a recent ~2 weeks old snapshot.
for wireless I use an ath5k type of controller.
/boot/common/settings/network/wireless_network is set up correctly
When I go to the network preferences menu
atheroswifi is disabled after every boot up. I must enable it.
When I enable it,by selecting DHCP and look at system log, DHCP_Discover get all the corect values for resolv.conf (nameserver), gateway and the "your_address"
After DHCP_DICOVER a DHCP_REQUEST is sent to the “your_address” this also gets the correct values but does not get a value for the "your_address"
This may be alright???, but when I execute an ifconfig the device net address “your_address” is missing.
The net does not work. The DNS (nameserver) address cannot be pinged.
Any ideas?

Note: without /boot/common/settings/network/wireless_network and using ifconfig join net name password, will nor work either.

Hi hunnia1234,

I don’t know the causes of your issue, but in anyway the name of the config file must be “wireless_networks” not “wireless_network”…

In anyway this config file don’t work for me… I can join automatically only with ifconfig parameter!


Detailed bugreports, with logs and all should be filed at the bugtracker. I, too, have no luck with my notebook’s iprowifi3945. The wireless_networks file seems to be problematic as well, as it sometimes doesn’t work for people where doing the manual ifconfig way does…


Thank you. I forgot about the bugtracker. Since I used it long time ago, I reset the password. Got in e-mail my username and new password and the logon link.
However the system does not accepts the new combination. I tried it on Linux (Chromium and Firefox) and windows on Explorer.
Would you be so kind to cat and paste my wpa problem on the bugtracker.
Thank you