Word Processor for Haiku?

looks interesting. is it available?

Hi lelldorin,

Kim posted the image of running the linux version on Haiku, and it does require Java being installed on your system. I installed the Linux version from the Joeffice website. After I downloaded and unpacked it, I used the following command that Kim provided:

/boot/home/joeffice/bin/joeffice --nospacecheck

This brought up the installer. I unchecked the boxes to install links to the Application Menu, along with the desktop as I thought that might give the installer some problems. I created the links after the install was complete.

So far I haven’t had any issues using it. I downloaded an Excel .xslx document this morning from an automobile forum, and it had no problems opening it. I’m still in the process of seeing how usuable Joeffice will be.

dasouth i download the sh script (14MiB) put it does not run:

/boot/system/non-packaged/apps/joffice> /boot/system/non-packaged/apps/joffice/joeffice.sh
Configuring the installer...
Can`t get the number of the available blocks on the system

Can you exlaint the complete steps to do it?


Hi lelldorin,

Download the Linux .sh script from Joeffice website

I ran the sh script from a folder named Downloads in my home directory

/boot/home/Downloads/joeffice.sh --nospacecheck

This created the .Joeffice installer folder in my home directory and started the Joeffice installer

During the install process, I let the installer create a Joeffice folder within my home directory (within this directory it creates folders named bin, etc, ide, Joeffice, platform and an uninstall.sh). Also during the install, I unselected letting the installer create links to the desktop and the Application menu.

Once the installer finished, I then ran the following:


This started the Joeffice application and created the .joeffice folder within the home directory.

I then created links to my desktop and the Application menu to



If you are still having issues installing Joeffice after following the steps above, I can also create a zip file with the necessary folders to try running Joeffice from your home directory. I haven’t had the chance yet to learn how to create hpkgs. Although, I can still create the old software pkgs.

If i get it running i can make a hpkg file for it. But first i need to see the license to see if i have the rights to do that.

I does not get it running, because the installer breaks every time between 10 and 30 percent

Which Haiku nightly-build are you using?

When I installed Joeffice I was using build 50558, and I’ve since upgraded to build 50562.

The first time I ran the installer, I did have it freeze on me. I ran the installer again, and the installer started again from scratch, and did a complete install.

I just did a fresh install of Ver 50562 to troubleshoot the installation problem, and the only pkg that I added was OpenJdk. I did create the Download folderin my home directory, and ran the Linux sh script from there.

The installation proceeded smoothly till 51% complete and then the installer froze. I stopped the installation and noticed that I was getting multiple instances of both Java and bash running. Subsequent installation attempts failled at 12% and 8% respectively.

I then deleted the Joeffice folder and the ./Joeffice-installer folder in my home directory and reboot the machine. I then changed directory to my Download folder and ran the ./joeffice.sh command. This time the installation went smoothly and the installation completed.

I took multiple screenshots to try to help folks out,so forgive me, if there are too many. I’ll post them as soon, as I install Qupzilla, as I can’t post images from Webpositive

1 Like

Joeffice looks really interesting, but it looks like it stopped being developed after Alpha 1. Any plans or idea to continue the development?

Hello kp3ft-b, i am using the Haiku rev 50443

Now, i am try again (sixed times) and it installs allready. The desktop icon does not start the program (after set permisson to executable too). But starting the program from terminal runs.

I have create a little tutorial, how to install Jeoffice on Haiku:


Translation into english later. But you can use the included google translate function.

The install does have some quirks. Besides having to do multiple attempts to get Joeffice to install, it appears that the desktop icon can be buggy. In both of my installs, after the initial running of Joeffice by the command line I’ve been able to use the desktop and Application menu links without any changes to permissions.

This is because descript version of Joeffice are build for Linux and therefore the scripts also build on it.

Yep! I’ve made a zip file of Joeffice, so that I don’t need to play with the installer. Tested using the zip file to install it, and I haven’t had any trouble using Joeffice.

Out of curiosity, I played with another Java installer for Linux on a Java web browser called Lobo, and I was able to install Lobo-098.3 which is quite dated. This version was one of the last versions that used Openjdk-1.7. Newer releases of it use OpenJdk-1.8.

i installed joeffice and it works. But only the Word Tool work, the other ones like spreadsheet, presentation and so on not.

I think, that something in haiku is missing to use that, can be?

Best regards