Wireless password?

Hi, I am fortunate enough to have a Wireless card that works by default with Haiku. It asks me at every logon for my password. Is there a way to stop this and have Haiku remember it?



Take a look at “Automatically connecting to a wireless network” on this page https://www.haiku-os.org/guides/daily-tasks/wireless

in my R1A4 install there is no /boot/system/settings/network/wireless_networks

in fact there is no /boot/system/settings/ at all

nor can I find any obviously equivalent location, or any settings file with wireless in the name anywhere

what’s up here?

does the guide actually refer to a different version of Haiku?

Hiya and welcome :slight_smile:

That Alpha is quite old now, I’d suggest downloading a installing the latest nightly rev from here: http://download.haiku-os.org/nightly-images/x86_gcc2_hybrid/


thanks, I will download a nightly, and try it. I had guessed that was probably the way to go in general since it has been so long since an official release.

but shouldn’t the instruction page refer to the officially released build? or at least say what version it works with? it is strongly implied at the top of the page that the instructions on it work with R1A4.

thanks for noticing that was my first post. :slight_smile: I’m really enjoying haiku, not least that it is usable - even responsive - on an old netbook! I’ll save my many questions and suggestions until I’ve tried a more recent build.

No worries, hope you enjoy it :slight_smile:

Feel free to ask and if you find any bugs, it’d be great if you’d log them here: https://dev.haiku-os.org/ (if it hasn’t yet, there’s a search function).


Hi tomato!

If wireless_networks doesn’t yet exist, you can just create it. That said, for me using such a settings file never worked…
Instead I went with the “add the ifconfig line” to ~/config/settings/boot/UserBootscript that is also described in the WLAN workshop of the user guide.

There should be equivalent folders in R1alpha4, but in general it’s recommended to use a nightly…


i installed the latest nightly, and the wifi now works and remembers my accesspoint name and password without having to edit the file at all. (which does exist now though)

the ethernet internet also works, which it didn’t quite with R1a4

Great success!! :slight_smile: