WiFi woes: Realtek RTL8191SEvB, hrev50173, Lenovo ThinkPad T400

I’m a reltive newbie to Haiku, having been experimenting with it off and on for just a couple of months, and have so far been unable to get WiFi working.

My computer is a Lenovo ThinkPad T400, currently running the latest nightly (hrev50173), with a Realtek RTL8191SEvB wireless LAN controller on the PCI bus.

The relevant section of the listdev output is:

device Network controller [2|80|0]
vendor 10ec: Realtek Semiconductor Co., Ltd.
device 8172: RTL8191SEvB Wireless LAN Controller

The Devices app reports the following (on the “Detailed” tab):

Class info: Network controller
Device name: RTL8191SEvB Wireless LAN Controller
Device paths: Not implemented
device/bus: pci
device/flags: 1
device/id: 0x8172
device/interface: 0x0
device/subtype: 0x80
device/type: 0x2
device/vendor: 0x10ec
Driver used: Not implemented
Manufacturer: Realtek Semiconductor Co., Ltd.
pci/bus: 3
pci/device: 0
pci/domain: 0
pci/function: 0

The rtl81xx and rtl8139 drivers are both present in /boot/system/add-ons/kernel/drivers/bin/

The wired controller is an Intel device that functions perfectly (I’m posting this from within Haiku using that interface currently).

Any ideas or suggestions on what I can do to get this working? Am I missing something somewhere?

TIA for any assistance you can provide.


The RTL8139 surely wired, and if i’ve seen correctly, the rtl81xx also a wired chip. Maybe there is a magic in Haiku and it is using wired driver to drive the wlan cards, but i have no idea about that. There was some wlan driver in the good ol’ BeOS times what worked that way, so maybe.

First you can check the “ifconfig” output in terminal. If you see booth of your interfaces, then there is a chance to get it work. The Devices and the listdev output just lists every hardware, so it doesn’t means that they are supported.

If you don’t see your wlan NIC in the ifconfig output, then swapping the wlan card to something supported is your only way. Check the supported device list here: https://www.haiku-os.org/guides/daily-tasks/wireless

Be warned: the Thinkapds have wlan card whitelist in the BIOS, and will work just with the whitelisted cards (or you can use modified BIOS, but be careful, you can brick easily your laptop that way. As you can see, there is some models with intel wlan NIC, what supported: http://aspeers.blogspot.com/2011/12/test-notebook-lenovo-thinkpad-t400.html

Is other hardwares supported well with Haiku?

Best Regards,

First, thank you for your interest in Haiku! Unfortunately, it would appear this wasn’t the right card to pick for it, though! I was going to look into it, but just one quick look at the FreeBSD forums explained it (link: https://forums.freebsd.org/threads/6144/ ), as they have trouble with that card as well. To explain, since Haiku’s wifi stack is based/built around the BSD implementation, it would make total sense that it’s having trouble if they are. You’re welcome to install non-free firmware (install-wifi-firmwares), which just might maybe have something close to that card, but I doubt it.

My advice would be to try the wired connection instead for now, or connect a different card and try that (before swapping them out, look at the cards Haiku supports which you can find here: https://www.haiku-os.org/docs/welcome/en/wifi.html , and here: https://www.haiku-os.org/guides/daily-tasks/wireless . Also, by extension, you could always see the list from BSD). Another option is that you could create a wireless network bridge through Windows, RHEL, etc., connect Haiku to it over Ethernet, and although you’d have to bring another tethered laptop with you, it would (temporarily) solve the problem (tip: if you have a Mac with 10.2 or later on it, just turn on Internet Sharing through AirPort to Ethernet, and give that a try). Or, otherwise, why not try out Haiku on a different machine? It may work better for you until support for said card arrives.

And as a side note, this is the reason why I, and others, are trying to maintain compatibility lists, so that it is easy to tell what Haiku runs on well (and on what hardware to avoid); if you’d like, I can add this one and make a note of the Realtek card problem for others with the same model.

I hope this helps and wish you luck!

Thank you both for your responses, even if they weren’t quite what I was hoping to hear.

I was actually into BeOS back in the day, and even acquired an original BeBox, which I still have (and it still works!)…I had been unaware of Haiku, however, until reading about it in a recent OS roundup published by the British “Linux Format” magazine, at which point I had to try it out.

I wasn’t actually given a choice about the card; it was what was pre-installed in this laptop when I purchased it (used) a few months ago. I’ve tried installing the non-free firmware, with about as much success as you expected, which is to say, none.

I’ll look into swapping out the card for a better-supported model; I’ll just have to search around to find the service manual for this machine and see what I might be able to find. I could easily run Haiku from within a VirtualBox VM on another partition on this laptop, though that sacrifices the speed advantage gained from running on bare metal. This computer is currently set up to triple-boot Haiku with Win 7 Pro and Ubuntu 15.10 - and while the VM route is an option, I’d prefer to run Haiku natively if I can. In the interim, I’ll have to limit my network activity to my home, where I have a wired connection readily available (I find the idea of carrying a second laptop simply for the purpose of tethering it to my Haiku box to provide WiFi access somewhat less than appealing).

[quote=apgreimann]And as a side note, this is the reason why I, and others, are trying to maintain compatibility lists, so that it is easy to tell what Haiku runs on well (and on what hardware to avoid); if you’d like, I can add this one and make a note of the Realtek card problem for others with the same model.

I hope this helps and wish you luck![/quote]

By all means, please do add this card to the list of those known not to work; perhaps it will help someone else who may find him/herself in the same situation at some point in the future. (For the record, I haven’t gotten sound working yet either, but that’s a topic for another post - I’ve downloaded the OSS drivers without any luck so far, but haven’t really devoted much effort to tracking down the problem yet. As I said, a topic for another post at a later date.)

Thanks again for your help!

–Az (Dave)