Wifi support for thinkpad T40


#1

Hello i have just tried haiku on my thinkpad T40 it finds the onboard ethernet ok, but unfortunately does not find the wifi card, will you be supporting wifi on the thinkpad T40?
thanks


#2

https://www.haiku-os.org/guides/daily-tasks

To support a large number of wireless cards with reduced legwork, the Haiku wireless network drivers are FreeBSD wireless drivers wrapped in code to translate them to the Haiku driver subsystem.

Non-Supported Hardware

aironetwifi at least
Cisco Aironet 350 Series
Aironet PCI4500
Aironet PCI4800

The following Broadcom 43xx devices:
bcm4311: vendor 14e4, device 4311
bcm4312: vendor 14e4, device 4315

As of R1A4, only PCI, PCI-X, PCI-Express, Mini PCI, and Mini PCI-Express devices are expected to work. PCMCIA, CardBus, ExpressCard, USB and ISA devices do not have the needed glue code to operate at this time.


#3

Welcome to the Haiku shell.

~> listdev

device Network controller [2|80|0]
vendor 8086: Intel Corporation
device 088e: Centrino Advanced-N 6235

WiFi work fine.


#4

There are several configurations of T40 fitted with different WiFi chipsets. Do you know which one you have? You might try using the listdev command from a shell and paste the output if you don’t know what any of it means.


#5

Hello it is detecting:

device 1043: PRO/WIRELESS LAN 2100 3B Mini PCI Adaptor

however in Network under devices it only shows the onboard ethernet not the wifi adaptor


#6

ok so i had to install the firmware using the download script, after that a reboot and it showed up in the network manager


#7

Taking advantage of the topic not to create a new discussion is possible rtl 8187b no haiku


#8

How did you install the firmware using the download script. I’m having the same issue as you on a t450s. I install the firmware listed in Haikudepot, but that didn’t solve the issue.


#9

The output of the listdev command and your syslog file would be helpful in figuring out the problem it’s hard to know what to tell you without more detailed information about your system.


#10

Are you sure you need the firmware’s? They are required for ooold cards, afaik.
Maybe your hw just simply unsupported.


#11

They are needed for the T40 at least. For the T450s, I have no idea.


#12

Probably Intel Dual Band Wireless-N or AC 7265.


#13

The wifi works if I install OS ‘normally’. If I install with efiboot, wifi not shown in network preferences. Any ideas?