Wifi says password wrong

I cant connect to my wifi it says password wrong but it is correct what should i do
My wifi dongle is “Sitecom Europe B.V.” “WL -343 Wireless USB Adapter 150N X1” ver. 0101

I think this is the only error message to indicate a failed login. It should be reworded to indicate the login failed without specifically mentioning the password or at least have another different error message.

The likely culprit is the wifi dongle driver used. The network drivers used with Haiku originated from one of the BSD operating systems.

I tried searching the forum but all the previous threads didn’t spell out the subject so plainly. Should this thread be merged with one of the others? Or maybe the other threads should be cited in a link from this thread?

I am a freebsd user my dongle works in freebsd but its not work in haiku

Thanks! That may help to narrow it down.

1 Like

Another inform It show my wifi name but it just says my password wrong
And thanks for replying

1 Like

These problems should be reported on the bugtracker which gives us proper tools for organizing the information. On the forums there is not much we can do.

When reported on the bugtracker, the issues are also listed on the “known problems” hage of the beta4 release so then we can hoint people there


If this is on a laptop, (or a keyboard with embedded numbers), check that the Number Lock isn’t ‘on’.

1 Like

Tried didn’t work