Wifi is not working on my laptop


I’m trying Haiku on my laptop (Asus Intel Corei5 8th gen). My wirleless cards is recognized as Intel 8265/8275 by the system but in the main menu I see /dev/net/idualwifi7260/0: No link.

What can I do to connect to my wi-fi network?


The /dev/net/idualwifi7260/0 driver is the same one that my Acer Travelmate laptop also uses,and for me it works perfectly fine with Haiku.
What exactly doesn’t work for you?
Does it find networks and fails to connect,or does it not find any networks at all?
What is the error message if it fails to connect?

1 Like

Hi, thanks for replying.

I don’t see any particular error message. When I open the WiFi info it’s completelly blank (I can’t send a screenshot because I’m using my second laptop here because… I can’t connect from Haiku :rofl: ).

In any case, I don’t see any wifi networks listed either…

If I open Network preferences I see the Mac address is completely blank (00:00:00…:00) and the Network dropdown is also empty

I did some more research to find a cause for that problem.
Looks like,while the driver used is the same,your hardware differs from mine.
My laptop has Wireless 7265 and yours 8265.
That the correct Mac address isn’t shown indicates a driver failure,for me it’s shown.
As far as I know,our idualwifi7260 driver is a port of OpenBSDs iwm driver.
That one should also support your Wireless 8265 hardware,as you can see here: iwm(4) - OpenBSD manual pages
Some OpenBSD users also say that they’re using the 8265 and it works for them: https://teddit.net/r/openbsd/comments/9qf1oh/intel_8265_wireless_support/
Sorry,that’s all I can say about it,and it’s probably not that helpful for you.
It should theoretically work but somehow doesn’t :confused:


Do you have an option to use a wired network with your laptop ?

I know - nowadays, it can be problematic : both in case your network device and/or laptop machine may lack of the Ethernet port.

Also I see - your question was about WiFi and that is not accidental … :))
… however, here, in the forum, often suggested to use some USB device to replace built-in WiFi card or use wired Ethernet for network access. You may consider to try one of it out.
Also exists some mobile hub you can connect to the Ethernet port on your laptop and you can use it to connect via this hub to your WiFi network.

1 Like

Thanks for sharing. I could use the ethernet as a temporary measure (like for downloading a different driver) but I’m afraid that’d be a no-go for me if I can’t fix it :frowning:

At the moment I use Linux and I’m looking for alternatives and Haiku looks interesting but… I still need to get work done :rofl:

1 Like

Normally I would have suggested the same,that’s the best workaround we have for unsupported wifi chip.
But in this specific case I really think there’s hope to get the internal wifi chip to work.
Our idualwifi7260 driver should support that chip,and someone from the Haiku developer team may be able to debug why it doesn’t work here.

Oh,by the way,maybe the syslog contains something that explains why it doesn’t work.
@mchojrin can you please upload your syslog?

1 Like

Are you using EFI/UEFI boot? In case yes, try to boot in legacy mode.

Also interesting question of Haiku version …

… aru you on more stable R1 Beta4 ?


… are you on a cutting edge, but may be less reliable Nightly version ?

In my case also worked better 32bit version - I had some issue when I first tried 64bit as it is booting with UEFI only and for that my other machine was not capable - this one now the firmware is in Legacy mode, so actually I do not bother to switch to :))
but so I do a new probing round - just as I succeed to create a 64 bit USB thumb drive – under Haiku … 8D

1 Like

Please open a ticket at https://dev.haiku-os.org

All this speculation in this thread is nice but no real help, on the bugtracker a developer can help investigate and fix this bug.