Why Doesn't Wifi Work?


I typed in the “install-wifi-firmwares.sh” and it said it installed successfully, but I can’t connect to wifi.

When I hook up to lan, it said “/dev/net/broadcom570x/0”. But if I disconnect from lan and use “ifconfig /dev/net/broadcom570x/0 dlink” it says that “’/dev/net/broadcom570x/0’ is not a WLAN device!”

I just typed in the device, and it gave me this:

Hardware type: Ethernet, Address: 88:ae:1d:86:22:c1
Media type: 100 MBit, 100BASE-TX
inet addr:, Bcast:, Mask:
MTU: 1500, Metric: 0, up broadcast link auto-configured
Receive: 5797 packets, 0 errors, 5631765 bytes, 0 mcasts, 0 dropped
Transmit: 4776 packets, 0 errors, 636847 bytes, 0 mcasts, 0 dropped
Collisions: 0

How can I get wifi to work?


I can’t comment on your broadcom card, but I had very little problem in getting a wifi connection on my EeePC 901 which has a Ralink RT2860 card with WPA2 encryption.

Essentially, I just followed what’s explained in the wiki on wireless connections.
One difference, however, is that I didn’t have to install a binary firmware module for this card.

The steps I followed were:

  1. Install optional package wpa_supplicant
  2. run the command
    ifconfig /dev/net/ralink2860/0 list
    to list available networks.
  3. Choose one network and run this command
    ifconfig /dev/net/ralink2860/0 join wifi_interface_name wifi_interface_password
    (obviously substituting the relevant name and password for your network).

Nothing more than this and I had a wifi connection.



I was checking the WiFi connection on my Acer Laptop (Travelmate 4280) in order to help “nitt” and some funny/strange things are happening:
(the Acer WiFi has a prowifi3945 -Intel- chipset)

1- after booting, checking the Deskbar icon for network I can see all netcards listed but no WiFi network name.
2- checking the settings of the prowifi3945 in “Open network preferences…” in the Deskbar network icon the prowifi3945 is listed as if it were a LAN-Ethernet card only (not WLAN-WiFi)
3- launching “wpa_supplicant” from a terminal I got no messages but the cursor goes new-line (then I do Ctrl-C to get rid of the “pending” command).

4- after a while of the command 3- above and going back to 2- I see finally the prowifi3945 listed as WiFi along with other settings like Network: name and Mode:

5- doing apply on the screen of 4- I get a screen for Open/WEP/WPA/WPA2 selection and password input.

6- I can go no further because I don’t know the password :frowning: (this is NOT my network) and I do Cancel.

7- However if from a terminal I enter “ifconfig /dev/net/prowifi3945/0 join network-name” OR the same but only with “join” (no network-name) I got this message:

ifconfig: “/dev/net/prowifi3945/0” is not a WLAN device!

which sounds quite strange indeed because I know it is a WLAN device and almost connected to a WiFi network (missing password…)

What happens?! (the graphical part seems to work better than the CLI commands).
Running wpa_supplicant from a terminal is also quite strange (it should be launched automatically from somewhere else) - what am I doing wrong?!

PS.: the broadcom570x (/dev/net/broadcom570x/0) is always seen/listed as a LAN card (NOT WLAN-WIFI) under Open network preferences… (as in 2- above)

Just some findings…and I hope this can be useful.

Best regards,

Roberto B.


The message that firmware was installed “successfully” does not mean that now WiFi will work, it only means that the files were installed ready for Haiku to use them. This message would appear if you have a WiFi device that’s not supported by Haiku, or even if you don’t have any wireless chipset at all.

The device /dev/net/broadcom570x/0 you have provided information about is a wired network chip, hence the “not a WLAN device” message.

You need to find information about your wireless network chipset.


This may be a dumb question, but how do I launch the wpa_supplicant? >.>

You’re like “launch it from the terminal”, but how? I don’t know the command to launch wpa_supplicant.

Atheros AR5B97 Wireless Network Adapter
Manufacturer: Atheros Communications Inc.
Location: PCI bus 4, device 0, function 0
Driver Version:


Haiku lacks a working driver for this device


This could be considered an heresy but…
why porting drivers from bsd if they really suck at them? wouldn’t it be better port them from GNU/Linux? is this impossible?


These drivers are usually under the GPL, and Haiku is licensed under BSD. And far as I know, the GPL can not be combined with BSD.

Apart from this problem, it’s the BSD license( MIT, x11, whatever) is very comfortable :).

Sorry for my english…


Atheros AR5B97 Wireless Network Adapter

Haiku lacks a working driver for this device[/quote]


Why?! They should put a driver for my device because I can’t use an operating system that can’t connect to WiFi.


The reason for using BSD drivers instead of Linux drivers is that Haiku has a compatibility layer for FreeBSD network drivers. That means that we’ll get all those drivers for free, without having to port and maintain them. As to why exactly FreeBSD was chosen, I don’t know. Maybe that was easier, cleaner, more licence-compatible, or all of that…

As a quick websearch turned out, the Atheros AR5B97 isn’t yet supported by FreeBSD, but has a chance to appear in FreeBSD 9. They planned to release v9 in September, so I guess that’ll be available Real Soon Now.
I suggest filing an enhancement ticket at Haiku’s bugtracker as a reminder to have another look once FreeBSD 9 is out.



Atheros AR5B97 Wireless Network Adapter

Haiku lacks a working driver for this device[/quote]

Soooo… It’s been five months… almost half of a year… does Haiku support this chipset yet?


Atheros AR5B97 should be supported in current nightlies. The driver name is atheroswifi. Please have a try!


I have a problem like that. But I am using a pendrive flashed with Haiku. Do I have to install it to have WiFi working?