Why does this?

I was about to install Beos on a pc that I have to make BeBox replicate but I don’t understand when I try to install it comes up with this writing … I’m sure it’s not a hardware problem as I tried the cd on 5 pc and does the usual defect on everyone ??? CD defective ???IMG_20200505_142215

Are these all new PCs? BeOS may not run very well at all on anything newer than 2005ish and was really not intended for anyhting more than 1Ghz PCs and 512MB ram (I forget the exact limits)… Also try and find a BeOS Max installer as it is pre patched for boot bugs IIRC.

Edit: it appears Archive.org has copies of BeOS Max so look there. Also note the version there is not the last version you might have to hunt a bit more for BeOS 5.0 Max 4 (note this is based on BeOS PE with some things preinstalled and fixes to the boot)

You can figure out the filenames from here and search for them, also note the boot images with ram limiter support may be of use and can be found in the zip image of BeOS Max they probably work with stock BeOS 5 also.

Note it has been quite awhile since I installed BeOS, and that was on a Tyan Thunder 2 ATX (similar to the official BeOS demo machines you can see on youtube). Also tried it out on a socket 939 Sempron, I think the only thing not working there was my ethernet and the video was grey by default probalby easily fixed by installing updated nvidia drivers as I was using an Nvidia Geforce 2 MX 400 there, and a Radeon 9800 Pro on the other system (r350 GPU).

I downloaded beos max edition v4b1 … I burned … I go to install and in the end I get this message out.
Before I destroy everything anyone knows what it means ???IMG_20200505_215045

Review your HD and provide a little info on your five computers (i.e. all the same model or not).
Something basic like: Dell Optiplex GX110 (being more specific is your choice)

1 Like

Honestly don’t remember having that problem… maybe the HDD is too big? dunno… Also pretty sure BeOS has to be on a primary partition and there may be other restrictions.

As was said, BeOS was written long ago, and will just not work:

  • if you have more than 1GB of RAM (even less sometimes) (because it tries to map it in the kernel portion of the virtual space) (some patches exist for the bootloader though, and some kernel cache settings might help in border cases)
  • if you run at more than 2GHz (bad cast in the clock calibration that screws up, and that I fixed in ZETA)

Not even mentioning the number or hardware not existing back then (SATA controllers…), and the buggy chipsets (I discovered a but in the ATI IXP chipset and had to work around it in ZETA and Haiku as well)…


As I think we discussed on the thread about recreating a BeBox - BeOS really won’t boot on anything much these days. You really need to pick your hardware carefully.

I still maintain that using Haiku, you will get a lot further. When I last ran BeOS it was on Pentium 3 class hardware maximum, with < 512MiB RAM and hard disks in to single GiB’s in size.

Even Zeta 1.1 refuses to boot on my netbook that runs Haiku (MSi Wind u100 with 250GiB hard drive, 2GiB RAM, Atom 32bit processor.) Haiku boots and recognises most of the hardware (no sound, no webcam) and runs well.

after hours of tests and trials I managed to install beos max edition v4b1 on a pentium III @ 800 Mhz dual processor, SB live sound card, Matrox G400 dual head video card (by the way how do I have two video outputs? ???), 512 Mb ram, 18 Gb hard drive … About the hard disk …
it was this bastard who sent the installer into crisis making me get to the end of the installation but then stopping when he wrote the boot loader … I partitioned a couple of hard disks with a FAT32 file system and then formatted them. … to the installer’s question to initialize I replied yes and I started the installation … it came to the bottom without any problem … I just don’t understand why, for example, the hard disk was partitioned NTFS or other file system even if it was initialized the installer crashed … However now it works

for @memson … you won’t be able to drag me to the dark side of Haiku :slight_smile: :slight_smile: :slight_smile:

I remember to successfully install BeOS on logical partition. However, I also remember BFS had 60 GB limit at that time.

alpopa, what version of BeOS was it?
I have an Edirol DV-7 series machine here happily running BeOS 5.03 from a 80GB hdd and with a secondary 120GB hdd for extra storage also formatted in BFS…

I think I have a project in mind - get both my old PowerPC kit out of storage (stored at another house and quarantine stops me from getting when I might actually have time to play with it!!) And get some hardware to run classic BeOS x86 :wink:

@lorezan, back then I had HDD less than 60 GB, so it is irrelevant what version it was. This information was from some documentation, I don’t remember exactly from where.

There was a bug in the original makebfs iirc. It was fixed in the early Haiku days by Bruno and/or Axel.

Edit: I suspect that some less official distros (cough cough Max, cough Developer Edition) have the fixed version included.

1 Like