Where to get Qt4 packages?

Qt4 packages have been removed from HaikuPorts, but some software still need it such as Dukto or HiQDock. Porting Dukto to Qt5 is not trivial and it is very important software for me.

Is it possible to restore Qt4 packages?

I have seen some Dukto Qt5 forks at github (search for dukto all github, set recent first), i built already 2 different, but while the main window shows up i was not able to verify the functionality), maybe that could be a solution for you.

I can’t build Qt5 Dukto. It complains about missing component.

I also had that problem, but using a different one worked without requiring any changes. I think this was which i used: https://github.com/ttys3/dukto

It run but not working. Also many buttons have no effect when clicked. This is recent fork, I haven’t seen it before.

We want to upload them to our repo

Socket listening seems broken in Qt5 port.

Qt4 netstat:

udp         0      0 *:4644                -                                  40214/Dukto
tcp         0      0 *:4644                *:*                   listen       40214/Dukto

Qt5 netstat:

udp         0      0 -                     -                                  40252/dukto
tcp         0      0 -                     -                     listen       40252/dukto

Note that port is missing on Qt5. Same problem with other Qt5 programs that use QTcpServer.

Cast @3dEyes

… i’ve been try maybe 4 different source of qt5 version of ducto… none works altough some of them compileable

I build Qt5 with debugprint in network module.
QNativeSocketEngine try first create AF_INET6 socket, and it’s created but not worked.
If i disable AF_INET6 and use only AF_INET - QTCPSever works fine.


Some flags need to be passed to QTcpServer or Qt5 port should be fixed? Why Telegram is working?

Telegram - tcp client, not server.

If set domain to AF_INET always - QTCPServer works fine.


it’s not clear what to do with this knowledge.
Until better times set AF_INET for sockets?

So it is kernel bug related to IPv6 handling?

I don’t know. Maybe something is not implemented.

I was also surprised that qt4 was deleted. I made the qt4 package for myself, it is in my repository http://repo.hakilo.ru/x86_64/ (64bit) and http://repo.hakilo.ru/x86_gcc2/ (32bit)


I managed to get Dukto from https://github.com/ttys3/dukto working on Qt5, but broadcast and IP list is not working. When Haiku Dukto is started, it is not added to Dukto list on another PCs, but when Dukto is started on another PC, it is added to haiku Dukto list. QNetworkInterface::allInterfaces() and QNetworkInterface::allAddresses seems not working properly.

I created HaikuPorts poll request: https://github.com/haikuports/haikuports/pull/5120.

Both client (the one running on Haiku, the other on my Blackberry) sees eachother, i can send files from the phone, but not to it. However i can send text it both direction.
Still great to have yet another way to transfer files.


Qt4 package avaiable on software.besly.de x86 and 64bit.

Regards lorglas