Where is BOOTX64.EFI?


#1

The UEFI install guide that is linked to in the Beta 1 RC1 announcement says that I need to create a directory structure like this on a partition:

EFI/BOOT/BOOTX64.EFI

However, it doesn’t mention where to get the BOOTX64.EFI file from. I did try to mount the uefi partition on my USB stick to see if the file was there but Haiku just gave a “General system error” message and refused mounting. Where do I copy the file from?


#2

I believe you should get it from the install media’s EUFI partition. I just looked at the haiku-release-anyboot.iso I have (64-bit) and it only has the BeFS partition.


#3

It does come with a uefi partition on my end, but mounting it results in this:


#4

Okay. I had the first one, not the corrected one. So I grabbed and it tried to mount it and I’m seeing the same thing that you are. I can mount the anyboot-efi.iso EUFI partition, though.


#5

https://dev.haiku-os.org/ticket/14539
https://dev.haiku-os.org/ticket/14540


#6

So there’s no way to install Haiku at all on current hardware.


#7

There are plenty ways, the easiest would be : attach the Haiku install disk to linux, mount the efi vol, copy the efi file to a different fat formatted usb, now you can place the file where you want. Its just easy.


#8

*no easy way to install haiku using EFI on current hardware.

I saw this last night… not sure if we want to do a rc2 because of it… I could just throw the haiku_loader.efi into the release as a separate download… not ideal :expressionless:


#9

Nobody should be editing their system EFI partition with Haiku, IMO. Just mount the Haiku EFI partition from another OS.


#10

Meh, that’s not ideal.

We were supposed to have a UEFI which included our loader available on the os volume (from haiku_loader*.hpkg), but the developer working on it had some real-life issues resulting in the work not getting done in time.

I had to hack in the UEFI loader to the install media at the last second to just make sure it was included for testing.

The real impact is you can’t (easily) install haiku to a hard drive with the UEFI bootloader. You can boot from UEFI and install to the hard disk with MBR/BIOS boot (as usual).

It’s not ideal, however, hopefully we’ll improve things in r1beta2 (which shouldn’t be another 5 years away :P)


#11

Thanks, I managed to mount the EFI partition in Linux and copy over BOOTX64.EFI, and now it works. Finally Haiku is completely installed and running on an SSD, on my Coffee Lake PC.