What's the best way to browse web apps such as Google Colab?

Hi All,

Just installed Haiku on an old acer one (1 gb ram, 320 gb hdd) machine, :-), and its amazing that haiku has breathed life into this machne that I could never think it was possible. Now I am going to install Haiku in my other machines. The nagging thing about Haiku is that, although webpositive is very good, it does not work with all sites. For example sites such as Google Colab, or most webapp like websites such as Medium don ot work as well (slow loading or does not load at all or crashes). Is there a way or hack to make webpositive work with these sites that I am missing or should know? I have tried Otter and Gnome Web but they are worse in terms of speed and loading, so these are not options at the moment. Would greatly appreciate your advice.


how about the application " Falkon "?
which version you download ?
32bite or 64bite ?

" What are the minimum hardware requirements to run Haiku?

The x86 32-bit release of Haiku will run on a Pentium or better CPU with 384 MiB of RAM (as long as virtual memory is activated), 1.5 GiB of storage space and a VESA compliant video card.

However, for a satisfactory user experience, we recommend at least a Pentium4 with 512 MiB of RAM and 3 GiB of storage space. For compiling Haiku within itself, we recommend using at least 2 GiB of RAM."

Much better! Thanks for this suggestion.

I downloaded the x86_64 version of the OS. The hardware as I wrote is 1 gb RAM and 320 gb HDD. This barely meets the RAM requirement but the OS is remarkably good. There are a few software I need for day to day work, eg Julia and pandoc, but I can wait or work towards building them. Meanwhile I really need a robust browser. Falkon looks terrific!

It is 3 to 4 times the requirements. Doesn’t count as “barely meets” to me :slight_smile:

Pandoc will require Haskell, which has been a bit tricky to get running so far. It seems ghc is good at catching obscure bugs in our C library and threads support. I hope we’ll get there eventually!

1 Like

Yes, true, :slight_smile:
But for that matter, I tried many different Linux flavours on this machine in the past, but with none of them I had the performance I have experienced with Haiku!

1 Like

Atleast not that I know off, if you know some basic C++ there is ample oportunity to help out though.

Underlying webpositive is haikuwebkit which is a fork of webkit that also is used by safari on apple devices. The engine is solid, and it can be ported very natively. Just our ports has some problems.

If falkon works for you for the moment that is a good stopgap. Unfortunately some crashes in falkon occur and severall haiku developers tried to investigate… but the chromium codebase is hard to debug, it’s really a blackbox. : )


Tackled julia a few time with no luck, if you can it would be great! :slight_smile:

I was going to answer that if there was a hack, we would have done it by default already.

But that is not exactly true. One thing you can do is install hblock, which is a DSN based ad blocker. It will prevent ads and other nuisances from loading. Suddenly, all webpages will be a lot simpler, and probably WebPositive can handle a lot more of it.

Just to clarify why it is that way: Haiku does several things to make the UI always react as fast as possible. Overall, if you do benchmarks, the system will actually often mesure quite slow (although we’re improving that). But, by giving priority to user-visible things, the system as a whole (computer+user) is a lot more efficient :slight_smile:


Thanks a million @PulkoMandy for the explanation.
Now I have run into another issue, perhaps need to raise a seprate thread. I installed Haiku on my second machine, a Thknkpad X220i, that has an SSD hard drive. I formatted the hard drive and then installed Haiku as my only operating system. During installation, when I tried to use the bootmanager to set up the boot menu it did not set up the boot menu on the Kingston SSD hard drive.

I then followed the instructions as explained here: UEFI Booting Haiku | Haiku Project
I named the partition as EFIBOOT, then renamed /efiboot to /efi, added a boot directory and placed the haiku_loader.efi in the boot subdirectory under efi directory.

So, specifically, this is what I did:

The Partition Layout

  • I chose a GPT disk system on the target device.
  • I created a 64 MiB partition at the start of the disk.
    • Set it at “EFI system data” type.
    • Formatted as FAT32, labelled “EFI”
  • Created Haiku partition (~ 30 gb)
    • Formatted as BeFS, label “Haiku”
      The post installation,

I mounted the “EFI” partition
Then in the /efi folder, created a boot subfolder (mkdir boot)
Copied the /boot/system/data/platform_loaders/haiku_loader.efi to /efi/boot

Then when I tried to reboot, the computer did not reboot, instead it went into the BIOS menu and it listed Grub-uefi as the first entry but that did not do anything.

But when I inserted the Haiku USB (from where I installed the system), and hit ESC key, it then booted into the new installed system. At that point, even if I remove the USB drive, it does not matter.

What do I need to do so the system can boot without the USB inserted?