What does it mean by 'could not find the mixer'?


#1

Hey guys, freshman here. I install the HAIKU OS in my VMware Workstation to further observe this lovely system.
But when I want to use it to play music. This problem came out: It shows that ‘could not find the mixer’ and it can’t play music.
So please please can anyone please tell me what does it mean by saying that?
%E6%97%A0%E6%A0%87%E9%A2%98


#2

Unsupported audio hw/virtualized hw.
Install opensound from Depot (available only for 32 bit Haiku).


#3

Thank you so much!
Mua~


#4

But sudden I find that my sys is 64-bit…:rofl:


#5

Next time you could try the “Search” function.


#6

Oh, sorry about that…Freshman here…


#7

I thought VMware did support Intel HDA or AC97. Have you checked your settings in VMware?


#8

I am using a Dell laptop whose soundcard is ‘Realtek® Audio’ or some thing like that…
So emmm, do Haiku support that?
I don’t know.


#9

image
So is that the right thing?


#10

If you use a virtual machine, your real hardware is irrelevant, as long as it works in the host OS (in this case windows).


#11

Hello @Tide, and welcome!

Did you tried to use VirtualBox (instead of VMWare)?

Another solution could be installing on VMWare the 32 bits Haiku version, and then, the OpenSound drivers.


#12

VMware Player doesn’t let you change the emulated sound device within the GUI it seems. You will need to edit the .vmx file manually, and change sound.virtualDev to hdaudio.


#13

Yes, thanks.
I’ve done that.
OpenSound do works on the 32-bits ver.
image


#14

hello @waddlesplash splash
You mean in 64-bit ver or the 32-bit ver?
I re-install the 64-bit ver and open it’s .vmx file

but I could not find such sound.virtualDev stuff…

Here are all the things in .vmx file

.encoding = “GBK”
config.version = “8”
virtualHW.version = “14”
pciBridge0.present = “TRUE”
pciBridge4.present = “TRUE”
pciBridge4.virtualDev = “pcieRootPort”
pciBridge4.functions = “8”
pciBridge5.present = “TRUE”
pciBridge5.virtualDev = “pcieRootPort”
pciBridge5.functions = “8”
pciBridge6.present = “TRUE”
pciBridge6.virtualDev = “pcieRootPort”
pciBridge6.functions = “8”
pciBridge7.present = “TRUE”
pciBridge7.virtualDev = “pcieRootPort”
pciBridge7.functions = “8”
vmci0.present = “TRUE”
hpet0.present = “TRUE”
displayName = “其他 (2)”
guestOS = “other”
nvram = “其他 (2).nvram”
virtualHW.productCompatibility = “hosted”
powerType.powerOff = “soft”
powerType.powerOn = “soft”
powerType.suspend = “soft”
powerType.reset = “soft”
tools.syncTime = “FALSE”
sound.autoDetect = “TRUE”
sound.fileName = “-1”
sound.present = “TRUE”
memsize = “1024”
ide1:1.fileName = “其他 (2).vmdk”
ide1:1.present = “TRUE”
ide1:0.deviceType = “cdrom-image”
ide1:0.fileName = “C:\Users\ajinj\Downloads\haiku-release-anyboot.iso”
ide1:0.present = “TRUE”
ethernet0.connectionType = “nat”
ethernet0.addressType = “generated”
ethernet0.present = “TRUE”
extendedConfigFile = “其他 (2).vmxf”
floppy0.present = “FALSE”
numa.autosize.cookie = “10001”
numa.autosize.vcpu.maxPerVirtualNode = “1”
uuid.bios = “56 4d e0 a0 9a eb bb 0a-d7 74 53 14 e9 c1 52 dd”
uuid.location = “56 4d e0 a0 9a eb bb 0a-d7 74 53 14 e9 c1 52 dd”
migrate.hostlog = “.\其他 (2)-3a2ab0a3.hlog”
ide1:1.redo = “”
pciBridge0.pciSlotNumber = “17”
pciBridge4.pciSlotNumber = “21”
pciBridge5.pciSlotNumber = “22”
pciBridge6.pciSlotNumber = “23”
pciBridge7.pciSlotNumber = “24”
ethernet0.pciSlotNumber = “32”
sound.pciSlotNumber = “33”
vmci0.pciSlotNumber = “34”
ethernet0.generatedAddress = “00:0c:29:c1:52:dd”
ethernet0.generatedAddressOffset = “0”
vmci0.id = “-373206307”
monitor.phys_bits_used = “43”
vmotion.checkpointFBSize = “33554432”
vmotion.checkpointSVGAPrimarySize = “33554432”
cleanShutdown = “TRUE”
softPowerOff = “FALSE”


#15

There is sound.autoDetect = "TRUE" – add sound.virtualDev = "hdaudio" above this.


#16

image

I am wondering if I’ve understand you through the language obstacle.
Yes, I did this. But it seems not works…
image


#17

still thanks for your enthusiastic help~


#18

Yes, I just tried this myself and it seems VMware’s HDA device has some quirks we need to account for. I’ve made a few hacks and got it to work locally; I’ll clean them up and push the fix later today.


#19

Done, the fix is hrev52562~1. New builds should be available in a few hours.


#20

I just tried it in VMware Workstation 15.0.1 and while it works the sound is choppy. It hickups every 2-5 seconds.